summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 17:48:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 17:50:03 +0200
commit70a4d56ed241a93887cd16d7b390cab7e2bff5e6 (patch)
treea5429f0c3367fca311b9927ebdd8c3a84eaed286 /media-gfx
parentmedia-libs/portmidi: EAPI-6 bump (diff)
downloadgentoo-70a4d56ed241a93887cd16d7b390cab7e2bff5e6.tar.gz
gentoo-70a4d56ed241a93887cd16d7b390cab7e2bff5e6.tar.bz2
gentoo-70a4d56ed241a93887cd16d7b390cab7e2bff5e6.zip
media-gfx/autopano-sift-C: EAPI-6 bump, drop superfluous versionator
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild15
-rw-r--r--media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch4
2 files changed, 10 insertions, 9 deletions
diff --git a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
index 3e9405ae1588..6bf149ec6034 100644
--- a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
+++ b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit cmake-utils eutils versionator
+EAPI=6
+
+inherit cmake-utils
DESCRIPTION="SIFT algorithm for automatic panorama creation in C"
HOMEPAGE="http://hugin.sourceforge.net/ http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
@@ -13,15 +14,15 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-S=${WORKDIR}/${PN}-"$(get_version_component_range 1-3)"
-
-RDEPEND="!media-gfx/autopano-sift
+DEPEND="
dev-libs/libxml2
media-libs/libpano13:0=
media-libs/libpng:0=
media-libs/tiff:0=
sys-libs/zlib
virtual/jpeg:0"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}
+ !media-gfx/autopano-sift
+"
PATCHES=( "${FILESDIR}"/${P}-lm.patch )
diff --git a/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch
index 97619975d9b6..e6141fffc0ae 100644
--- a/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch
+++ b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch
@@ -1,8 +1,8 @@
Link against -lm (mathlib) because ScaleSpace.c (which is part of the internal libsift.a)
is using the exp() function, see http://bugs.gentoo.org/472150
---- CMakeLists.txt
-+++ CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -121,7 +121,7 @@
ADD_LIBRARY(libsift STATIC ${LIBSIFT_SOURCES})