summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-02-10 00:45:02 -0600
committerTim Harder <radhermit@gentoo.org>2019-02-10 00:46:47 -0600
commit7de7bd180041457c3fee742b6550f0665fe4d0cd (patch)
tree1b3ec3c6cce9a0981e73683ae64e040e222724a4 /media-gfx
parentnet-misc/autossh: version bump to 1.4g (diff)
downloadgentoo-7de7bd180041457c3fee742b6550f0665fe4d0cd.tar.gz
gentoo-7de7bd180041457c3fee742b6550f0665fe4d0cd.tar.bz2
gentoo-7de7bd180041457c3fee742b6550f0665fe4d0cd.zip
media-gfx/sxiv: version bump to 25
Closes: https://bugs.gentoo.org/657784 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sxiv/Manifest1
-rw-r--r--media-gfx/sxiv/sxiv-25.ebuild62
-rw-r--r--media-gfx/sxiv/sxiv-9999.ebuild8
3 files changed, 67 insertions, 4 deletions
diff --git a/media-gfx/sxiv/Manifest b/media-gfx/sxiv/Manifest
index 6b5fce29bccb..7a1c803da895 100644
--- a/media-gfx/sxiv/Manifest
+++ b/media-gfx/sxiv/Manifest
@@ -1 +1,2 @@
DIST sxiv-24.tar.gz 47148 BLAKE2B 69d70d64ea6cf6ae7a044d06df78a2e1e53941ef281d6445f54a28c4368112674461bc4e71a0226946588e604de33dd0972960cb072a00efd64512e5273cef09 SHA512 e4c9d4e18b4f1999b6441256b4c0d4683a105f1f64d4f754d6f9bc4f467ee1ccc6b6996cec8a210276c5fbec59417627fb838cb4f7be37cce32fa2c5d45d347b
+DIST sxiv-25.tar.gz 48814 BLAKE2B 17ef2ff0e75acd6acce068dfc17dfbce78bb1a38b652e948b5f88902adcbae504e9322c92d125b71c511a95c7e8e47b58060ff58e2c804a7296b5a801d3fc0e8 SHA512 ca0d834c9982c5e98c0bae51d21b7d08692af2d692eeb2ac55e19c4da7d09b16bbaa8022af0a0d00c52def4120058d895f37a2f8b14f453a0ceb65eebe564814
diff --git a/media-gfx/sxiv/sxiv-25.ebuild b/media-gfx/sxiv/sxiv-25.ebuild
new file mode 100644
index 000000000000..3b3917053a8f
--- /dev/null
+++ b/media-gfx/sxiv/sxiv-25.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop xdg-utils gnome2-utils savedconfig toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/muennich/sxiv.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/muennich/sxiv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple (or small or suckless) X Image Viewer"
+HOMEPAGE="https://github.com/muennich/sxiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="exif gif +jpeg +png"
+
+RDEPEND="
+ exif? ( media-libs/libexif )
+ gif? ( media-libs/giflib:0= )
+ media-libs/imlib2[X,gif?,jpeg?,png?]
+ x11-libs/libX11
+ x11-libs/libXft
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ restore_config config.h
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" HAVE_LIBEXIF=$(usex exif 1 0) HAVE_GIFLIB=$(usex gif 1 0)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ emake -C icon DESTDIR="${ED}" PREFIX=/usr install
+ dodoc README.md
+ domenu sxiv.desktop
+
+ save_config config.h
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-gfx/sxiv/sxiv-9999.ebuild b/media-gfx/sxiv/sxiv-9999.ebuild
index 778e21dde204..3b3917053a8f 100644
--- a/media-gfx/sxiv/sxiv-9999.ebuild
+++ b/media-gfx/sxiv/sxiv-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils xdg-utils gnome2-utils savedconfig toolchain-funcs
+inherit desktop xdg-utils gnome2-utils savedconfig toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/muennich/sxiv.git"
@@ -18,12 +18,12 @@ HOMEPAGE="https://github.com/muennich/sxiv/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="exif gif"
+IUSE="exif gif +jpeg +png"
RDEPEND="
exif? ( media-libs/libexif )
gif? ( media-libs/giflib:0= )
- media-libs/imlib2[X,gif?]
+ media-libs/imlib2[X,gif?,jpeg?,png?]
x11-libs/libX11
x11-libs/libXft
"