summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-29 01:02:09 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-29 01:09:17 +0100
commitab195d04a2d8aa01292c94908329065f9e4f8fa9 (patch)
treebe8b4f9aca03d311c2fd69746bc0d9aee06a8fc7 /media-gfx
parentnet-dns/pdns: Revision bump for security fixes to 4.1.0_rc3 (diff)
downloadgentoo-ab195d04a2d8aa01292c94908329065f9e4f8fa9.tar.gz
gentoo-ab195d04a2d8aa01292c94908329065f9e4f8fa9.tar.bz2
gentoo-ab195d04a2d8aa01292c94908329065f9e4f8fa9.zip
media-gfx/libimagequant: Bump to v2.11.4
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/libimagequant/Manifest1
-rw-r--r--media-gfx/libimagequant/libimagequant-2.11.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/libimagequant/Manifest b/media-gfx/libimagequant/Manifest
index c74854f01b3d..1140301b5492 100644
--- a/media-gfx/libimagequant/Manifest
+++ b/media-gfx/libimagequant/Manifest
@@ -1 +1,2 @@
DIST libimagequant-2.10.1.tar.gz 70783 SHA256 c06f6d33611b90b57ed362752c9fe4819f6c51896b3024010f18744dc14ce0f7 SHA512 1cbb725e5f3774f931379f640c6532e169ea02a7b502a93af6b75a305e3dab1bd34a375391be0e8fdc15fea578715e8f8319d95d674383b7048e5f73e48b106f WHIRLPOOL 654407abec0b565b9ead32b427e2393be760a012eaba8d657c4b5fd9d75f729af98be5bcdeea99487419ef91d347dbb86598f3719992401ec49ee8adcef0e9a0
+DIST libimagequant-2.11.4.tar.gz 74117 BLAKE2B 5d42dc876c77694a1d4576e633d2e3aa1e531061aa849a683542cf11b14333f65125bbae699f927bf42896a934ade6d745aa517d6cbc4b7097d96c7579532ec9 SHA512 e9d2aaac2f37968dc93ba0da7d03f0fcf60b3f17d9a0b9edfd6930eade25844dd603de74492d8e1de8dc2da4e7f3e47959a558b5a67588d71e9e1db035eca1cc
diff --git a/media-gfx/libimagequant/libimagequant-2.11.4.ebuild b/media-gfx/libimagequant/libimagequant-2.11.4.ebuild
new file mode 100644
index 000000000000..db64a5c57738
--- /dev/null
+++ b/media-gfx/libimagequant/libimagequant-2.11.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Palette quantization library that powers pngquant and other PNG optimizers"
+HOMEPAGE="https://pngquant.org/lib/"
+SRC_URI="https://github.com/ImageOptim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_sse2 debug openmp static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ tc-export AR CC
+ # Hand rolled configure script, so not all flags are supported.
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ $(use debug && echo --enable-debug) \
+ $(use_enable cpu_flags_x86_sse2 sse) \
+ $(use_with openmp) \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_compile() {
+ emake shared || die "make failed"
+ use static-libs && (emake static || die "make failed")
+}
+
+src_install() {
+ dolib.so libimagequant.so
+ dolib.so libimagequant.so.*
+ use static-libs && dolib.a libimagequant.a
+ doheader libimagequant.h
+ einstalldocs
+}