summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 11:25:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 11:33:04 +0100
commitddbf062159321c203f918f3795c076521073576f (patch)
tree707ffd38be1f5158b0c6ec9e00b5d5d921dd2e66 /media-gfx
parentdev-libs/libansilove: new package; add version 1.2.8 and live (diff)
downloadgentoo-ddbf062159321c203f918f3795c076521073576f.tar.gz
gentoo-ddbf062159321c203f918f3795c076521073576f.tar.bz2
gentoo-ddbf062159321c203f918f3795c076521073576f.zip
media-gfx/ansilove: new package; add version 4.1.5 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ansilove/Manifest1
-rw-r--r--media-gfx/ansilove/ansilove-4.1.5.ebuild30
-rw-r--r--media-gfx/ansilove/ansilove-9999.ebuild30
-rw-r--r--media-gfx/ansilove/metadata.xml26
4 files changed, 87 insertions, 0 deletions
diff --git a/media-gfx/ansilove/Manifest b/media-gfx/ansilove/Manifest
new file mode 100644
index 000000000000..a37ef743844a
--- /dev/null
+++ b/media-gfx/ansilove/Manifest
@@ -0,0 +1 @@
+DIST ansilove-4.1.5.tar.gz 41325 BLAKE2B fa0943406b5a905f30fd114ed9760a37da1bcb7bd8bb7575272d1cffadaf0302650c65af64e97f911cff7b9eb4283bedd6fc0fc13c9aa5be88c582c44925c30b SHA512 a84253b07d82b4d0598cf6936115476933636a978805fe243a671bbdbe15d0e589b45f9e4d7b6137e5f7ab22559b9d1a84a0508db5226ccc17e20687e190e553
diff --git a/media-gfx/ansilove/ansilove-4.1.5.ebuild b/media-gfx/ansilove/ansilove-4.1.5.ebuild
new file mode 100644
index 000000000000..747102f7845f
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-4.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://github.com/ansilove/ansilove/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}
diff --git a/media-gfx/ansilove/ansilove-9999.ebuild b/media-gfx/ansilove/ansilove-9999.ebuild
new file mode 100644
index 000000000000..747102f7845f
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://github.com/ansilove/ansilove/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}
diff --git a/media-gfx/ansilove/metadata.xml b/media-gfx/ansilove/metadata.xml
new file mode 100644
index 000000000000..30ea50ab6723
--- /dev/null
+++ b/media-gfx/ansilove/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ AnsiLove is an ANSI and ASCII art to PNG converter, allowing to convert
+ ANSI and artscene-related file formats into PNG images, supporting ANSI
+ (.ANS), PCBoard (.PCB), Binary (.BIN), Artworx (.ADF), iCE Draw (.IDF),
+ Tundra (.TND) and XBin (.XB) formats.
+ It creates size optimized 4-bit PNG files and supports SAUCE (Standard
+ Architecture for Universal Comment Extensions), 80x25 and 80x50 PC fonts
+ (including all the 14 MS-DOS charsets), Amiga fonts, and iCE colors.
+ This is a complete rewrite of AnsiLove/PHP in the C programming language.
+ </longdescription>
+ <upstream>
+ <changelog>
+ https://github.com/ansilove/ansilove/blob/master/ChangeLog
+ </changelog>
+ <bugs-to>https://github.com/ansilove/ansilove/issues</bugs-to>
+ <remote-id type="github">ansilove/ansilove</remote-id>
+ </upstream>
+</pkgmetadata>