summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-10-12 00:00:34 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-10-12 00:00:49 +1100
commiteee92fc66783faa17112955812d026d205310001 (patch)
treefe7d66cc7214bf164589410b8a055cc57b7da037 /media-gfx
parentx11-misc/i3lock: Version 2.11 (diff)
downloadgentoo-eee92fc66783faa17112955812d026d205310001.tar.gz
gentoo-eee92fc66783faa17112955812d026d205310001.tar.bz2
gentoo-eee92fc66783faa17112955812d026d205310001.zip
media-gfx/engauge: fix build with Qt 5.11
Closes: https://bugs.gentoo.org/662476 Signed-off-by: Michael Palimaka <kensington@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/engauge/engauge-10.6.ebuild4
-rw-r--r--media-gfx/engauge/files/engauge-10.6-qt-5.11.patch26
2 files changed, 29 insertions, 1 deletions
diff --git a/media-gfx/engauge/engauge-10.6.ebuild b/media-gfx/engauge/engauge-10.6.ebuild
index ea7530fd0b5f..7d8aba7d2cce 100644
--- a/media-gfx/engauge/engauge-10.6.ebuild
+++ b/media-gfx/engauge/engauge-10.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,8 @@ S=$WORKDIR/engauge-digitizer-$PV
src_prepare() {
eapply_user
+ eapply "${FILESDIR}/${P}-qt-5.11.patch"
+
# Make sure the documentation is looked for in the proper directory
sed -e "s:engauge-digitizer/engauge.qhc:${PF}/engauge.qhc:" \
-i src/Help/HelpWindow.cpp || die
diff --git a/media-gfx/engauge/files/engauge-10.6-qt-5.11.patch b/media-gfx/engauge/files/engauge-10.6-qt-5.11.patch
new file mode 100644
index 000000000000..9070f5223939
--- /dev/null
+++ b/media-gfx/engauge/files/engauge-10.6-qt-5.11.patch
@@ -0,0 +1,26 @@
+Bug: https://bugs.gentoo.org/662476
+
+From 5eab86bf84dd1e52fc52b427a8f3508780811976 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Thu, 11 Oct 2018 23:51:15 +1100
+Subject: [PATCH] Add missing include.
+
+---
+ src/Load/LoadImageFromUrl.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Load/LoadImageFromUrl.cpp b/src/Load/LoadImageFromUrl.cpp
+index 684629bd..1150dad0 100644
+--- a/src/Load/LoadImageFromUrl.cpp
++++ b/src/Load/LoadImageFromUrl.cpp
+@@ -10,6 +10,7 @@
+ #include <QFileInfo>
+ #include <QMessageBox>
+ #include <QtNetwork/QNetworkReply>
++#include <QTextStream>
+ #include <QUrl>
+ #include "Version.h"
+
+--
+2.18.1
+