summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-05-06 12:59:05 +0200
committerPacho Ramos <pacho@gentoo.org>2019-05-06 13:04:55 +0200
commitf2016a230d28bbc09d40116343742544c19ecc91 (patch)
treec3636dc5fe8a0b5ff90006d652c3e135c5b68751 /media-gfx
parentmedia-gfx/gimp: Move sandbox fixes from src_compile to src_configure (diff)
downloadgentoo-f2016a230d28bbc09d40116343742544c19ecc91.tar.gz
gentoo-f2016a230d28bbc09d40116343742544c19ecc91.tar.bz2
gentoo-f2016a230d28bbc09d40116343742544c19ecc91.zip
media-gfx/gimp: Apply sandbox fixes to stable ebuild too
Closes: https://bugs.gentoo.org/684886 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/gimp-2.10.8-r1.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/media-gfx/gimp/gimp-2.10.8-r1.ebuild b/media-gfx/gimp/gimp-2.10.8-r1.ebuild
index 3c52ca4f773a..020456b1fee7 100644
--- a/media-gfx/gimp/gimp-2.10.8-r1.ebuild
+++ b/media-gfx/gimp/gimp-2.10.8-r1.ebuild
@@ -104,7 +104,23 @@ src_prepare() {
fgrep -q GIMP_DISABLE_DEPRECATED configure || die #615144, self-test
}
+_adjust_sandbox() {
+ # Bugs #569738 and #591214
+ local nv
+ for nv in /dev/nvidia-uvm /dev/nvidiactl /dev/nvidia{0..9} ; do
+ # We do not check for existence as they may show up later
+ # https://bugs.gentoo.org/show_bug.cgi?id=569738#c21
+ addwrite "${nv}"
+ done
+
+ addwrite /dev/dri/ # bugs #574038 and #684886
+ addwrite /dev/ati/ # bug #589198
+ addwrite /proc/mtrr # bug #589198
+}
+
src_configure() {
+ _adjust_sandbox
+
local myconf=(
GEGL="${EPREFIX}"/usr/bin/gegl-0.4
GDBUS_CODEGEN="${EPREFIX}"/bin/false
@@ -143,17 +159,6 @@ src_configure() {
}
src_compile() {
- # Bugs #569738 and #591214
- local nv
- for nv in /dev/nvidia-uvm /dev/nvidiactl /dev/nvidia{0..9} ; do
- # We do not check for existence as they may show up later
- # https://bugs.gentoo.org/show_bug.cgi?id=569738#c21
- addwrite "${nv}"
- done
- addwrite /dev/dri/ # bug #574038
- addwrite /dev/ati/ # bug 589198
- addwrite /proc/mtrr # bug 589198
-
export XDG_DATA_DIRS="${EPREFIX}"/usr/share # bug 587004
gnome2_src_compile
}