summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:41:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 10:04:15 +0200
commitf5e59029a11eb7b502f475865f781317bd679ee9 (patch)
tree22eb2fa0bfa8aef57fb4c1ed42cc234a10a4e418 /media-gfx
parentmail-client/claws-mail: Eradicate python2 (diff)
downloadgentoo-f5e59029a11eb7b502f475865f781317bd679ee9.tar.gz
gentoo-f5e59029a11eb7b502f475865f781317bd679ee9.tar.bz2
gentoo-f5e59029a11eb7b502f475865f781317bd679ee9.zip
media-gfx/alembic: Eradicate python2
Closes: https://bugs.gentoo.org/733456 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/alembic/alembic-1.7.11-r1.ebuild15
-rw-r--r--media-gfx/alembic/alembic-1.7.12.ebuild15
2 files changed, 8 insertions, 22 deletions
diff --git a/media-gfx/alembic/alembic-1.7.11-r1.ebuild b/media-gfx/alembic/alembic-1.7.11-r1.ebuild
index 8f112f0a4fd3..2132a431730c 100644
--- a/media-gfx/alembic/alembic-1.7.11-r1.ebuild
+++ b/media-gfx/alembic/alembic-1.7.11-r1.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake multiprocessing python-single-r1
+inherit cmake multiprocessing
DESCRIPTION="Open framework for storing and sharing scene data"
HOMEPAGE="https://www.alembic.io/"
@@ -15,25 +13,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="arnold +boost doc examples hdf5 maya prman python test zlib"
+IUSE="arnold +boost doc examples hdf5 maya prman test zlib"
RESTRICT="!test? ( test )"
-# pyalembic python bindings need boost
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
hdf5? ( zlib )
- python? ( boost )
"
RDEPEND="
${PYTHON_DEPS}
>=media-libs/openexr-2.3.0:=
+ boost? ( >=dev-libs/boost-1.65.0:= )
hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
- python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_SINGLE_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.11-r1 )
- $(python_gen_cond_dep '
- boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_MULTI_USEDEP}] )
- ')
"
DEPEND="
${RDEPEND}
@@ -72,7 +65,7 @@ src_configure() {
-DUSE_HDF5=$(usex hdf5)
-DUSE_MAYA=$(usex maya)
-DUSE_PRMAN=$(usex prman)
- -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_PYALEMBIC=OFF
-DUSE_TESTS=$(usex test)
)
cmake_src_configure
diff --git a/media-gfx/alembic/alembic-1.7.12.ebuild b/media-gfx/alembic/alembic-1.7.12.ebuild
index 8833c3fbfbb6..364b3261bc71 100644
--- a/media-gfx/alembic/alembic-1.7.12.ebuild
+++ b/media-gfx/alembic/alembic-1.7.12.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake multiprocessing python-single-r1
+inherit cmake multiprocessing
DESCRIPTION="Open framework for storing and sharing scene data"
HOMEPAGE="https://www.alembic.io/"
@@ -15,25 +13,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+boost doc examples hdf5 prman python test zlib"
+IUSE="+boost doc examples hdf5 prman test zlib"
RESTRICT="!test? ( test )"
-# pyalembic python bindings need boost
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
hdf5? ( zlib )
- python? ( boost )
"
RDEPEND="
${PYTHON_DEPS}
>=media-libs/openexr-2.3.0:=
+ boost? ( >=dev-libs/boost-1.65.0:= )
hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
- python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_SINGLE_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.11-r1 )
- $(python_gen_cond_dep '
- boost? ( >=dev-libs/boost-1.65.0:=[python?,${PYTHON_MULTI_USEDEP}] )
- ')
"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( >=app-doc/doxygen-1.8.14-r1 )"
@@ -70,7 +63,7 @@ src_configure() {
-DUSE_HDF5=$(usex hdf5)
-DUSE_MAYA=OFF
-DUSE_PRMAN=$(usex prman)
- -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_PYALEMBIC=OFF
-DUSE_TESTS=$(usex test)
)
cmake_src_configure