summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2021-07-15 17:17:37 +0300
committerSam James <sam@gentoo.org>2021-07-16 02:33:19 +0100
commitfa409ed342713271b505116594c59ca32e7e12d0 (patch)
tree63a1c43bd779d0189fbb1fe61809be54370512aa /media-gfx
parentnet-p2p/mldonkey: Patch for C++17 support. (diff)
downloadgentoo-fa409ed342713271b505116594c59ca32e7e12d0.tar.gz
gentoo-fa409ed342713271b505116594c59ca32e7e12d0.tar.bz2
gentoo-fa409ed342713271b505116594c59ca32e7e12d0.zip
media-gfx/hydrus: Add 447
Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hydrus/Manifest1
-rw-r--r--media-gfx/hydrus/hydrus-447.ebuild141
2 files changed, 142 insertions, 0 deletions
diff --git a/media-gfx/hydrus/Manifest b/media-gfx/hydrus/Manifest
index 771a7ab241b2..bd108a8a44d9 100644
--- a/media-gfx/hydrus/Manifest
+++ b/media-gfx/hydrus/Manifest
@@ -2,3 +2,4 @@ DIST hydrus-443.tar.gz 38823767 BLAKE2B 100b2c0650d3230b1c18e58417b731bd661fecde
DIST hydrus-444.tar.gz 38817103 BLAKE2B f9eb3dc346a1a7b8d45558ee69b0b9d2a7dbbb7018734680e9953f20ebd56209cc1874213ecf5515835f1022bf571a99543154843f7dc2b9375116db8ba080a0 SHA512 f5bc28e43a5218fce15bc9d197ebcc1f4eb47856a741ad79f59d1da2413a3e7e220381a4d8208fe880fa507e023f9c03050e46ab5214ef310d105df0d85a9682
DIST hydrus-445.tar.gz 38823389 BLAKE2B 3cd07a3e30e60bd8507fd58c027e5c5a96745163bd5982198448a65b957ff8f4308c9bc0ee73b883fa275689c900dff07f497634c07f4b2f7fe579e1e3d6f378 SHA512 6735468bd531786fef9a861a81ee1e34595c362450027a0c011593465ed77dc85a304a314dcb7031e30b2e90548b2497bb4f01932dc1f04e814b7dd5ae70617c
DIST hydrus-446.tar.gz 38830223 BLAKE2B 5ab44f9cfbd15eb10144135eb4cc1d8493c20f2a931db4332a61aa186fddff96cb3a3b29eb2b210f070bb4be8210d552beb2578a7287a169a7364f02363e05f4 SHA512 bdbcd1177c3bf6ee85089e1a653587bae41c524bc2313bb5d481dee074c7da1c533a91957dc3b03d1c0b515e705809887e290ac71b866a51664f2a9a34bbfb6b
+DIST hydrus-447.tar.gz 38833157 BLAKE2B 8d7cf37a1419ef40fa7816958a01421ecc335d2a8c975fcf16d3ea5dfbdb76d872e4e597bdbade28eff7727914de5de7fb6ffcc7ecc27a712410031efa8433fe SHA512 85eaab40f192f2414be828545464811af2590b55e1a2fea7bbf64f27e4bb9a8b6c6c86cb25c1f7e9f48449173f079dcd749ea25ed22559bebb11adddce62da94
diff --git a/media-gfx/hydrus/hydrus-447.ebuild b/media-gfx/hydrus/hydrus-447.ebuild
new file mode 100644
index 000000000000..abe83ba38720
--- /dev/null
+++ b/media-gfx/hydrus/hydrus-447.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 desktop optfeature
+
+DESCRIPTION="A booru-like media organizer for the desktop"
+HOMEPAGE="https://hydrusnetwork.github.io/hydrus/ https://github.com/hydrusnetwork/hydrus"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+else
+ SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+# hydrus itself is WTFPL
+# icons included are CC-BY-2.5
+LICENSE="WTFPL-2 CC-BY-2.5"
+SLOT="0"
+IUSE="+mpv +ffmpeg +lz4 socks +cloudscraper charts test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/psutil[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyside2[widgets,gui,charts?,${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ dev-python/service_identity[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ dev-python/twisted[${PYTHON_MULTI_USEDEP}]
+ media-libs/opencv[python,png,jpeg,${PYTHON_MULTI_USEDEP}]
+
+ >=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+
+ cloudscraper? ( dev-python/cloudscraper[${PYTHON_MULTI_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg )
+ lz4? ( dev-python/lz4[${PYTHON_MULTI_USEDEP}] )
+ mpv? (
+ media-video/mpv[libmpv,${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpv[${PYTHON_MULTI_USEDEP}]
+ )
+ socks? (
+ || ( dev-python/requests[socks5,${PYTHON_MULTI_USEDEP}]
+ dev-python/PySocks[${PYTHON_MULTI_USEDEP}] )
+ )
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/httmock[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
+"
+
+PATCHES=(
+ "${FILESDIR}/userpath-in-local-share.patch"
+)
+
+src_prepare() {
+ default
+
+ # Contains pre-built binaries for other systems and a broken swf renderer for linux
+ rm -r bin/ || die
+ # Build files used for CI, not actually needed
+ rm -r static/build_files || die
+ # Duplicate license file, not needed
+ rm license.txt || die
+ # Python requirements files, not needed
+ rm requirements_*.txt || die
+}
+
+src_compile() {
+ python_optimize "${S}"
+}
+
+src_test() {
+ # The tests use unittest, but are run with a custom runner script.
+ # QT_QPA_PLATFORM is required to make them run without X
+ local -x QT_QPA_PLATFORM=offscreen
+ "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+}
+
+src_install() {
+ local doc="${EPREFIX}/usr/share/doc/${PF}"
+ elog "Hydrus includes an excellent manual, that can either be viewed at"
+ elog "${doc}/html/help/index.html"
+ elog "or accessed through the hydrus help menu."
+
+ mv "help my client will not boot.txt" "help_my_client_will_not_boot.txt" || die
+
+ local DOCS=(COPYING README.md Readme.txt help_my_client_will_not_boot.txt db/)
+ local HTML_DOCS=("${S}"/help/)
+ einstalldocs
+
+ # Files only needed for testing
+ rm test.py hydrus/hydrus_test.py || die
+ rm -r hydrus/test/ static/testing/ || die
+
+ # These files are copied into doc
+ rm -r "${DOCS[@]}" "${HTML_DOCS[@]}" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ ln -s "${doc}/html/help" help || die
+
+ insinto /opt/hydrus
+ doins -r "${S}"/.
+
+ exeinto /usr/bin
+ python_newexe - hydrus-server < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-server")
+ python_newexe - hydrus-client < <(sed "s/python/${EPYTHON}/" "${FILESDIR}/hydrus-client")
+
+ make_desktop_entry "hydrus-client" "Hydrus Client" "/opt/hydrus/static/hydrus_non-transparent.png" \
+ "AudioVideo;FileTools;Graphics;Network;"
+}
+
+pkg_postinst() {
+ optfeature "support for automatic port forwarding" "net-libs/miniupnpc"
+}