summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-07-01 10:11:12 -0500
committerBen Kohler <bkohler@gentoo.org>2022-07-01 10:36:15 -0500
commitfb3d33c95ca3fcecbaacaa4edde1cd2d7003b9b9 (patch)
treeebfa627bb25cbf0920de068d43939b6667005b24 /media-gfx
parentmail-mta/msmtp: drop 1.8.16, 1.8.19 (diff)
downloadgentoo-fb3d33c95ca3fcecbaacaa4edde1cd2d7003b9b9.tar.gz
gentoo-fb3d33c95ca3fcecbaacaa4edde1cd2d7003b9b9.tar.bz2
gentoo-fb3d33c95ca3fcecbaacaa4edde1cd2d7003b9b9.zip
media-gfx/fotoxx: add 22.20
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-22.20.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index 290a0e762715..fbdc591aff04 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1,2 +1,3 @@
DIST fotoxx-22.16.tar.gz 8984376 BLAKE2B 4a5665313133405b4a53d7e40986e37601b5c9552f20c07d5f0889f3dacbabce1b4a712fcb216fe3358e7ad1de12da608961a996b081e4b3d644c5581ebcc6ee SHA512 ff78b0d7bbde0de5d98ac42d63c36f4bdcd425ae210dfcda6f64f4307be02dfca2966475df3f962751f73afc8e9442d2eb975725db31745109e174fe1665f804
DIST fotoxx-22.18.tar.gz 8917288 BLAKE2B 252e0e4a812e1f510da29f844f1f854f779c44f49d864952a5fb151f27bbac8af207308352f20ed976986cff8a6ce0a78f8d57b874d630d32a4d928f06dc820e SHA512 385a01201d18f75f5b2f6d2f3609c90fae7ba016279c42f3b0aaee65c0c28c71eae6d589ace71a9714629838d2de57ac93cb24c05339aadb6a3751e3081af795
+DIST fotoxx-22.20.tar.gz 8687337 BLAKE2B 013a1f154ea9971c5ff5c33f3ab62bcec9a364f0d47a65648b251966a0b798e00dd80ced399bcfb3657cf2e95534d1e694dc2d2c36066502ddc3b50a645cdba0 SHA512 c9b6cb298546ab121be6ef2c907ce51e4a4060a52829ed1ef51475ae1e542c7cb39037402381969519907a2a66bd8f741452786ff3a25f30fbbd22b24032a436
diff --git a/media-gfx/fotoxx/fotoxx-22.20.ebuild b/media-gfx/fotoxx/fotoxx-22.20.ebuild
new file mode 100644
index 000000000000..5819421d21bf
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-22.20.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}