summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-16 18:49:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-16 18:49:01 +0200
commit3c9e7fad2eb6f5052e23e9ee23b74de6dbca3673 (patch)
treecf078143689b4fe88a429c0ea04a69bba0e41160 /media-libs/aubio
parentmedia-sound/aqualung: fix build with ffmpeg git master. (diff)
downloadgentoo-3c9e7fad2eb6f5052e23e9ee23b74de6dbca3673.tar.gz
gentoo-3c9e7fad2eb6f5052e23e9ee23b74de6dbca3673.tar.bz2
gentoo-3c9e7fad2eb6f5052e23e9ee23b74de6dbca3673.zip
media-libs/aubio: fix build with ffmpeg git master.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/aubio')
-rw-r--r--media-libs/aubio/aubio-0.4.1.ebuild3
-rw-r--r--media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/media-libs/aubio/aubio-0.4.1.ebuild b/media-libs/aubio/aubio-0.4.1.ebuild
index dfddfdbff94a..3d8976b437ba 100644
--- a/media-libs/aubio/aubio-0.4.1.ebuild
+++ b/media-libs/aubio/aubio-0.4.1.ebuild
@@ -8,7 +8,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit distutils-r1 waf-utils multilib
+inherit distutils-r1 waf-utils multilib eutils
DESCRIPTION="Library for audio labelling"
HOMEPAGE="http://aubio.org/"
@@ -39,6 +39,7 @@ PYTHON_SRC_DIR="${S}/python"
src_prepare() {
sed -i -e "s:\/lib:\/$(get_libdir):" src/wscript_build || die
sed -i -e "s:doxygen:doxygen_disabled:" wscript || die
+ has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}/${PN}-0.4.1-ffmpeg29.patch"
}
src_configure() {
diff --git a/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch b/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch
new file mode 100644
index 000000000000..86562716d3e5
--- /dev/null
+++ b/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch
@@ -0,0 +1,22 @@
+Index: aubio-0.4.1/src/io/source_avcodec.c
+===================================================================
+--- aubio-0.4.1.orig/src/io/source_avcodec.c
++++ aubio-0.4.1/src/io/source_avcodec.c
+@@ -167,7 +167,7 @@ aubio_source_avcodec_t * new_aubio_sourc
+ }
+
+ AVFrame *avFrame = s->avFrame;
+- avFrame = avcodec_alloc_frame();
++ avFrame = av_frame_alloc();
+ if (!avFrame) {
+ AUBIO_ERR("source_avcodec: Could not allocate frame for (%s)\n", s->path);
+ }
+@@ -415,7 +415,7 @@ void del_aubio_source_avcodec(aubio_sour
+ }
+ s->output = NULL;
+ if (s->avFrame != NULL) {
+- avcodec_free_frame( &(s->avFrame) );
++ av_frame_free( &(s->avFrame) );
+ }
+ s->avFrame = NULL;
+ AUBIO_FREE(s);