summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-06-12 01:10:10 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-05 11:24:14 +0300
commitd4487daf3befb464be78a714cbd89e644a876967 (patch)
tree91d77e0a988a03158248b02667e095ae95f311dc /media-libs/babl
parentdev-ruby/itextomml: add ruby27 (diff)
downloadgentoo-d4487daf3befb464be78a714cbd89e644a876967.tar.gz
gentoo-d4487daf3befb464be78a714cbd89e644a876967.tar.bz2
gentoo-d4487daf3befb464be78a714cbd89e644a876967.zip
media-libs/babl: 0.1.78 version bump
Bug: https://bugs.gentoo.org/723868 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/Manifest1
-rw-r--r--media-libs/babl/babl-0.1.78.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/babl/Manifest b/media-libs/babl/Manifest
index e5bd89675be9..7d17525f4327 100644
--- a/media-libs/babl/Manifest
+++ b/media-libs/babl/Manifest
@@ -1,2 +1,3 @@
DIST babl-0.1.66.tar.bz2 706100 BLAKE2B 0de443dd4ea32cd025c8b121f042c24528677f32a6c201f3abedd13fb3a2ce2636d03f4b45eefce2c9f7a86426355af9b584602ca9ebb1a2140ee88f500c2843 SHA512 41534eea6cad21eae704af3fdce4857e9dc2b0efa48a7cfd7f98b23428198e95fc9ca2f30e522abf2fa06e907eaf4f7bbafc048b356cb5890fabcb9be21001b3
DIST babl-0.1.74.tar.xz 294156 BLAKE2B bb5df4db706f817d9cf8674caed9b758fc1380b9dd33a26b24990eae07543f097c5e5fb68788c02cb2a2c0e68e917bb7a1c68aa0d2f9871dfd3267934291d474 SHA512 97b4a5aad76b7d6dee1835774cee48f866a9513c6454d74c3378068a60359704c1ba106a7542b9ac6a7968b3cf632ed2626b835ec9c7f3fcc6e29968c1e39396
+DIST babl-0.1.78.tar.xz 298920 BLAKE2B 654baf0ed09fbbad54578bf8bba60f45152e446d8b3d3ee49ca57084f220d22ed9478bc95851c5c1b17deeacdacfc14a39ab4d6e3f0448012eb212eef8b357b2 SHA512 d40f68cbd3d7703066a8985958b6cc49eaefe842c0fb3b7bbf6a5d6e6198642b55c4f95bdbf0d25a29d24a975c9b94acfd084792c60b18ec5f66260dfe54893b
diff --git a/media-libs/babl/babl-0.1.78.ebuild b/media-libs/babl/babl-0.1.78.ebuild
new file mode 100644
index 000000000000..be6f45add6b0
--- /dev/null
+++ b/media-libs/babl/babl-0.1.78.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_USE_DEPEND=vapigen
+
+inherit meson gnome2-utils vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/babl.git"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="introspection lcms vala cpu_flags_x86_avx2 cpu_flags_x86_f16c cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1"
+REQUIRED_USE="vala? ( introspection )"
+
+BDEPEND="
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+RDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ local emesonargs=(
+ -Dwith-docs=false
+ $(meson_use introspection enable-gir)
+ $(meson_use lcms with-lcms)
+ $(meson_use vala enable-vapi)
+ $(meson_use cpu_flags_x86_avx2 enable-avx2)
+ $(meson_use cpu_flags_x86_f16c enable-f16c)
+ $(meson_use cpu_flags_x86_mmx enable-mmx)
+ $(meson_use cpu_flags_x86_sse enable-sse)
+ $(meson_use cpu_flags_x86_sse2 enable-sse2)
+ $(meson_use cpu_flags_x86_sse3 enable-sse3)
+ $(meson_use cpu_flags_x86_sse4_1 enable-sse4_1)
+ )
+ meson_src_configure
+}