summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/bio2jack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/bio2jack')
-rw-r--r--media-libs/bio2jack/Manifest1
-rw-r--r--media-libs/bio2jack/bio2jack-0.9-r1.ebuild44
-rw-r--r--media-libs/bio2jack/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/bio2jack/Manifest b/media-libs/bio2jack/Manifest
new file mode 100644
index 000000000000..9b3a8d13d2c2
--- /dev/null
+++ b/media-libs/bio2jack/Manifest
@@ -0,0 +1 @@
+DIST bio2jack-0.9.tar.gz 527385 SHA256 1695b1713341279b80cb51c7d3d793102c19793546bfff5b73e882f2e5dec9e8
diff --git a/media-libs/bio2jack/bio2jack-0.9-r1.ebuild b/media-libs/bio2jack/bio2jack-0.9-r1.ebuild
new file mode 100644
index 000000000000..791264938bd4
--- /dev/null
+++ b/media-libs/bio2jack/bio2jack-0.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="A library for porting blocked I/O OSS/ALSA audio applications to JACK"
+HOMEPAGE="http://bio2jack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bio2jack/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # upstream does not provide a real release, it releases a tarball
+ # with a _prebuilt_ copy of bio2jack. Drop all of the built stuff
+ # and recreate autotools from scratch, then build.
+ rm -rf *.a *.o *.la *.lo .libs .deps Makefile config.{log,status} stamp-h1 stamp || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dobin bio2jack-config
+ dodoc AUTHORS ChangeLog NEWS README
+ rm -f "${ED}"usr/lib*/lib*.la
+}
diff --git a/media-libs/bio2jack/metadata.xml b/media-libs/bio2jack/metadata.xml
new file mode 100644
index 000000000000..43393326f925
--- /dev/null
+++ b/media-libs/bio2jack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">bio2jack</remote-id>
+ </upstream>
+</pkgmetadata>