summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/ccaudio2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/ccaudio2')
-rw-r--r--media-libs/ccaudio2/Manifest1
-rw-r--r--media-libs/ccaudio2/ccaudio2-2.1.3.ebuild40
-rw-r--r--media-libs/ccaudio2/files/disable_gsm_automagic.patch25
-rw-r--r--media-libs/ccaudio2/metadata.xml13
4 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/ccaudio2/Manifest b/media-libs/ccaudio2/Manifest
new file mode 100644
index 000000000000..f1fbe4890732
--- /dev/null
+++ b/media-libs/ccaudio2/Manifest
@@ -0,0 +1 @@
+DIST ccaudio2-2.1.3.tar.gz 443867 SHA256 b94a898c9a2ae55c812bde810fdf89f40bc44b94fb06c4dc3e40a5341eeec301 SHA512 3f6d80a503ddacb473b559450a6fac0cba7f1788a7c17a0326b1ef66918a1403a1c69c1578fbd2f382e75969d95a116c579dae810cdd3719da24a3e25027b9ae WHIRLPOOL 9028655b082b67d28734e78b2356a80fa1066ebaefaf15d9a9be44939034484dc822114029bf0685e54cea9a891c614d863e47df1b482f3aa3eacb46e083d803
diff --git a/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild b/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
new file mode 100644
index 000000000000..ee2cafb45561
--- /dev/null
+++ b/media-libs/ccaudio2/ccaudio2-2.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit autotools-utils
+
+DESCRIPTION="C++ class framework for manipulating audio data"
+HOMEPAGE="http://www.gnu.org/software/ccaudio"
+SRC_URI="mirror://gnu/ccaudio/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug static-libs +speex gsm"
+
+RDEPEND="dev-libs/ucommon
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+PATCHES=("${FILESDIR}"/disable_gsm_automagic.patch)
+DOCS=(AUTHORS ChangeLog INSTALL NEWS README SUPPORT THANKS TODO)
+
+REQUIRED_USE="^^ ( gsm speex )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable speex)
+ $(use_enable gsm)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-libs/ccaudio2/files/disable_gsm_automagic.patch b/media-libs/ccaudio2/files/disable_gsm_automagic.patch
new file mode 100644
index 000000000000..1ae6a79239c7
--- /dev/null
+++ b/media-libs/ccaudio2/files/disable_gsm_automagic.patch
@@ -0,0 +1,25 @@
+--- configure.ac.orig 2011-05-15 21:40:14.000000000 +0300
++++ configure.ac 2011-05-15 21:46:11.000000000 +0300
+@@ -138,6 +138,9 @@
+ ac_gsm_codec=false
+ ac_spx_codec=false
+
++AC_ARG_ENABLE(gsm, [ --disable-gsm disable gsm support])
++if test "$enable_gsm" != "no" ; then
++
+ AC_CHECK_HEADER(gsm/gsm.h, [
+ ac_gsm_codec=true
+ AC_DEFINE(HAVE_GSM_GSM_H, [1], [gsm header found])
+@@ -145,9 +148,11 @@
+ ],[
+ AC_CHECK_HEADER(gsm.h, [
+ AUDIO_LIBS="$AUDIO_LIBS -lgsm"
+- AC_DEFINE(HAVE_GSM_H, [1], [gsm default header])
++ AC_DEFINE(HAVE_GSM_H, [1], [gsm default header])
++
+ ])
+ ])
++fi
+
+ AC_ARG_ENABLE(speex, [ --disable-speex disable speex support])
+ if test "$enable_speex" != "no" ; then
diff --git a/media-libs/ccaudio2/metadata.xml b/media-libs/ccaudio2/metadata.xml
new file mode 100644
index 000000000000..60c7f53239ef
--- /dev/null
+++ b/media-libs/ccaudio2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+</pkgmetadata>