summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-04 09:59:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-04 09:59:18 +0100
commitabd4482ee548c0cc3326b6ffbe249fa85c25f3a3 (patch)
tree3bd0a50e80e3337a8338dc6d4820a0317f89e3af /media-libs/celt/celt-0.11.3.ebuild
parentnet-libs/gnutls: version bump (diff)
downloadgentoo-abd4482ee548c0cc3326b6ffbe249fa85c25f3a3.tar.gz
gentoo-abd4482ee548c0cc3326b6ffbe249fa85c25f3a3.tar.bz2
gentoo-abd4482ee548c0cc3326b6ffbe249fa85c25f3a3.zip
media-libs/celt: Bump to version 0.11.3
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/celt/celt-0.11.3.ebuild')
-rw-r--r--media-libs/celt/celt-0.11.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/celt/celt-0.11.3.ebuild b/media-libs/celt/celt-0.11.3.ebuild
new file mode 100644
index 000000000000..78dfaecf7684
--- /dev/null
+++ b/media-libs/celt/celt-0.11.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ogg static-libs test"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+DOCS=( README TODO )
+
+src_prepare() {
+ default
+
+ if use test ; then
+ # tandem tests fail:
+ # https://thr3ads.net/opus/2012/09/2124778-CELT-0.11.3-tandem-test-fails
+ sed '/^TESTS/s@ tandem-test@@' -i tests/Makefile.am || die
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ # ogg is for the binaries
+ local myconf="--without-ogg"
+ multilib_is_native_abi && myconf="$(use_with ogg ogg /usr)"
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}