summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/celt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/celt')
-rw-r--r--media-libs/celt/Manifest2
-rw-r--r--media-libs/celt/celt-0.11.1-r1.ebuild35
-rw-r--r--media-libs/celt/celt-0.5.1.3.ebuild30
-rw-r--r--media-libs/celt/metadata.xml12
4 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/celt/Manifest b/media-libs/celt/Manifest
new file mode 100644
index 000000000000..918a3c59f92e
--- /dev/null
+++ b/media-libs/celt/Manifest
@@ -0,0 +1,2 @@
+DIST celt-0.11.1.tar.gz 465853 SHA256 01c2579fba8b283c9068cb704a70a6e654aa74ced064c091cafffbe6fb1d4cbf SHA512 73d17486ae0ef544baf74f7cf7d4b82b7dcba5143f480ffefec2c16ae9aa240d207aac4aa28c6888ba26e925f6d6f5545f71ef157b95906b63d017ce7b7ce842 WHIRLPOOL 7232af7abb58ef1fccc111a3ef74d1426bb807d3039067d8af37252cac4ba95395900903bbeff93257c6a097463ec3126a2d2ec14528449a0424a7db6dc23d8a
+DIST celt-0.5.1.3.tar.gz 440772 SHA256 fc2e5b68382eb436a38c3104684a6c494df9bde133c139fbba3ddb5d7eaa6a2e SHA512 bf5621dc3ec1b0808bdd83f006fd7b88df1b6caffe07e18eb696c268b31c6c7127329ecb4c9582c44e0ecf9577bbe2f3dbe40f15b80f8681bb7f4115f1501921 WHIRLPOOL 86355696a7aaef2d1dfc51526c29c5e39cdb6ef8e19cd23f8f49fa5b8d962ced8f395684c869a77bc67e20320c28ecf5c9d8bf8eb690f84bfccad3013736c3fd
diff --git a/media-libs/celt/celt-0.11.1-r1.ebuild b/media-libs/celt/celt-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..b7644e72dd9e
--- /dev/null
+++ b/media-libs/celt/celt-0.11.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ~ppc64 ~sparc x86"
+IUSE="ogg static-libs"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+DOCS=( README TODO )
+
+multilib_src_configure() {
+ # ogg is for the binaries
+ local myconf="--without-ogg"
+ multilib_is_native_abi && myconf="$(use_with ogg ogg /usr)"
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}
diff --git a/media-libs/celt/celt-0.5.1.3.ebuild b/media-libs/celt/celt-0.5.1.3.ebuild
new file mode 100644
index 000000000000..73c9cac86611
--- /dev/null
+++ b/media-libs/celt/celt-0.5.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0.5.1"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="ogg static-libs"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ogg ogg /usr)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc README TODO || die "dodoc failed."
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}
diff --git a/media-libs/celt/metadata.xml b/media-libs/celt/metadata.xml
new file mode 100644
index 000000000000..07e45eced00b
--- /dev/null
+++ b/media-libs/celt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>tgurr@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ CELT is a very low delay audio codec designed for high-quality
+ communications.
+ </longdescription>
+</pkgmetadata>