summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:36:23 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-10-14 02:36:23 +0200
commit4485260386ba034842b54a812f87f7133ddbd88f (patch)
tree63f81b5135876ef7efaea8ea048ae3dbd0fdfee4 /media-libs/coin
parentdev-libs/injeqt: no Werror (diff)
downloadgentoo-4485260386ba034842b54a812f87f7133ddbd88f.tar.gz
gentoo-4485260386ba034842b54a812f87f7133ddbd88f.tar.bz2
gentoo-4485260386ba034842b54a812f87f7133ddbd88f.zip
media-libs/coin: remove old, update remote-id in metadata.xml
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'media-libs/coin')
-rw-r--r--media-libs/coin/Manifest1
-rw-r--r--media-libs/coin/coin-3.1.3-r2.ebuild100
-rw-r--r--media-libs/coin/files/coin-3.1.0-javascript.patch38
-rw-r--r--media-libs/coin/files/coin-3.1.3-freetype251.patch28
-rw-r--r--media-libs/coin/files/coin-3.1.3-gcc-4.7.patch10
-rw-r--r--media-libs/coin/files/coin-3.1.3-gcc-7.patch21
-rw-r--r--media-libs/coin/files/coin-3.1.3-memhandler-initialization.patch23
-rw-r--r--media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch13
-rw-r--r--media-libs/coin/metadata.xml3
9 files changed, 1 insertions, 236 deletions
diff --git a/media-libs/coin/Manifest b/media-libs/coin/Manifest
index 0da91a6dc58f..05545c81b614 100644
--- a/media-libs/coin/Manifest
+++ b/media-libs/coin/Manifest
@@ -1,2 +1 @@
-DIST Coin-3.1.3.tar.gz 5981534 BLAKE2B 33f88149cf0bf7daeb32226e2deb29f9f36f2a29ca9fcf025f39bb50d3eb0bfc85113a1e96cf980c97d037419c3a263bcf6eccaeb2f289517304c59d4c9de919 SHA512 d6fd47ecc74e96fc4de46e3a683f038f1907b96db2bbe935fb49f2d59190bd18f3f439dc0e4cb435360e74e1d65994a32b21f670d5a76394692616625cb14394
DIST coin-4.0.0-src.tar.gz 6824162 BLAKE2B 9dee9397bb63c0da02214d33f2661051a3fd99689956a6de5c2cf806dd05944038b87b690f954f35711ee5e4ab07f04685681b822d0bbab0d7941bef551202dc SHA512 e036276a243bfe252569cee1b67d38b8633fcf35bdf4e366a92ca67e23799d54d91fe272c23b383c451d330cee284809f28f237857493948149e0da1ebd64fae
diff --git a/media-libs/coin/coin-3.1.3-r2.ebuild b/media-libs/coin/coin-3.1.3-r2.ebuild
deleted file mode 100644
index 6e2dfe73f617..000000000000
--- a/media-libs/coin/coin-3.1.3-r2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic
-
-MY_P=${P/c/C}
-
-DESCRIPTION="A high-level 3D graphics toolkit, fully compatible with SGI Open Inventor 2.1"
-HOMEPAGE="https://bitbucket.org/Coin3D/coin/wiki/Home"
-SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 PEL )"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="bzip2 debug doc javascript openal simage static-libs threads zlib"
-
-# NOTE: expat is not really needed as --enable-system-expat is broken
-RDEPEND="
- dev-libs/expat
- media-libs/fontconfig
- media-libs/freetype:2
- virtual/opengl
- virtual/glu
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- bzip2? ( app-arch/bzip2 )
- javascript? ( dev-lang/spidermonkey:0 )
- openal? ( media-libs/openal )
- simage? ( media-libs/simage )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
- doc? ( app-doc/doxygen )
-"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.0-javascript.patch
- "${FILESDIR}"/${P}-pkgconfig-partial.patch
- "${FILESDIR}"/${P}-gcc-4.7.patch
- "${FILESDIR}"/${P}-freetype251.patch
- "${FILESDIR}"/${P}-memhandler-initialization.patch
- "${FILESDIR}"/${P}-gcc-7.patch
-)
-
-DOCS=(
- AUTHORS FAQ FAQ.legal NEWS README RELNOTES THANKS
- docs/{ChangeLog.v${PV},HACKING,oiki-launch.txt}
-)
-
-src_configure() {
- append-cppflags -I"${EPREFIX}/usr/include/freetype2"
- # Prefer link-time linking over dlopen
- local myeconfargs=(
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- --disable-dl-fontconfig
- --disable-dl-freetype
- --disable-dl-libbzip2
- --disable-dl-openal
- --disable-dl-simage
- --disable-dl-zlib
- --disable-dyld
- --disable-loadlibrary
- --disable-man
- --disable-java-wrapper
- --enable-3ds-import
- --enable-compact
- --enable-dl-glu
- --enable-dl-spidermonkey
- --enable-system-expat
- --includedir="${EPREFIX}/usr/include/${PN}"
- --with-fontconfig
- --with-freetype
- $(use_with bzip2)
- $(use_enable debug)
- $(use_enable debug symbols)
- $(use_enable doc html)
- $(use_enable javascript javascript-api)
- $(use_with javascript spidermonkey)
- $(use_enable openal sound)
- $(use_with openal)
- $(use_with simage)
- $(use_enable threads threadsafe)
- $(use_with zlib)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- # Remove Coin from Libs.private
- sed -e '/Libs.private/s/ -lCoin//' -i "${BUILD_DIR}"/Coin.pc || die
-
- autotools-utils_src_install
-}
diff --git a/media-libs/coin/files/coin-3.1.0-javascript.patch b/media-libs/coin/files/coin-3.1.0-javascript.patch
deleted file mode 100644
index f45d9cd78cf6..000000000000
--- a/media-libs/coin/files/coin-3.1.0-javascript.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: src/vrml97/JS_VRMLClasses.h
-===================================================================
---- src/vrml97/JS_VRMLClasses.h (revision 13505)
-+++ src/vrml97/JS_VRMLClasses.h (revision 13506)
-@@ -28,6 +28,7 @@
- #error this is a private header file
- #endif /* ! COIN_INTERNAL */
-
-+#if defined(HAVE_VRML97) && defined(COIN_HAVE_JAVASCRIPT)
- /* ********************************************************************** */
-
- class SoJavaScriptEngine;
-@@ -37,5 +38,6 @@
- void JS_addVRMLclasses(SoJavaScriptEngine * engine);
-
- /* ********************************************************************** */
-+#endif // HAVE_VRML97 && COIN_HAVE_JAVASCRIPT
-
- #endif /* !COIN_JS_VRMLCLASSES_H */
-Index: src/vrml97/JS_VRMLClasses.cpp
-===================================================================
---- src/vrml97/JS_VRMLClasses.cpp (revision 13505)
-+++ src/vrml97/JS_VRMLClasses.cpp (revision 13506)
-@@ -2,7 +2,7 @@
- #include "config.h"
- #endif // HAVE_CONFIG_H
-
--#ifdef HAVE_VRML97
-+#if defined(HAVE_VRML97) && defined(COIN_HAVE_JAVASCRIPT)
-
- /**************************************************************************\
- *
-@@ -2097,4 +2097,4 @@
- MFVec3dHandler::jsval2field);
- }
-
--#endif // HAVE_VRML97
-+#endif // HAVE_VRML97 && COIN_HAVE_JAVASCRIPT
diff --git a/media-libs/coin/files/coin-3.1.3-freetype251.patch b/media-libs/coin/files/coin-3.1.3-freetype251.patch
deleted file mode 100644
index 44e8eefb1f63..000000000000
--- a/media-libs/coin/files/coin-3.1.3-freetype251.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- Coin-3.1.3/src/glue/freetype.cpp
-+++ Coin-3.1.3/src/glue/freetype.cpp
-@@ -52,9 +52,9 @@
- #ifdef HAVE_FREETYPE /* In case we're _not_ doing runtime linking. */
- #define FREETYPEGLUE_ASSUME_FREETYPE 1
- #include <ft2build.h>
--#include <freetype/freetype.h>
--#include <freetype/ftglyph.h>
--#include <freetype/ftoutln.h>
-+#include FT_FREETYPE_H
-+#include FT_GLYPH_H
-+#include FT_OUTLINE_H
- #endif /* FREETYPEGLUE_ASSUME_FREETYPE */
-
- #include <Inventor/C/basic.h>
---- Coin-3.1.3/src/glue/freetype.h
-+++ Coin-3.1.3/src/glue/freetype.h
-@@ -87,8 +87,8 @@
-
- #ifdef HAVE_FREETYPE
- #include <ft2build.h>
--#include <freetype/freetype.h>
--#include <freetype/ftglyph.h>
-+#include FT_FREETYPE_H
-+#include FT_GLYPH_H
- #else /* HAVE_FREETYPE */
-
- #include <Inventor/C/basic.h>
diff --git a/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch b/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch
deleted file mode 100644
index fd2430903802..000000000000
--- a/media-libs/coin/files/coin-3.1.3-gcc-4.7.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- coin3-3.1.3.orig/include/Inventor/SbBasic.h
-+++ coin3-3.1.3/include/Inventor/SbBasic.h
-@@ -24,6 +24,7 @@
- *
- \**************************************************************************/
-
-+#include <Inventor/C/errors/debugerror.h>
- #include <Inventor/C/basic.h>
-
- /* ********************************************************************** */
diff --git a/media-libs/coin/files/coin-3.1.3-gcc-7.patch b/media-libs/coin/files/coin-3.1.3-gcc-7.patch
deleted file mode 100644
index c1f1f560d851..000000000000
--- a/media-libs/coin/files/coin-3.1.3-gcc-7.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urN Coin-3.1.3.orig/src/3ds/SoStream.cpp Coin-3.1.3/src/3ds/SoStream.cpp
---- Coin-3.1.3.orig/src/3ds/SoStream.cpp 2010-03-02 16:20:09.000000000 +0300
-+++ Coin-3.1.3/src/3ds/SoStream.cpp 2017-07-23 15:04:43.808204691 +0300
-@@ -176,7 +176,7 @@
- if (!gotNum) { setBadBit(); return FALSE; } \
- \
- char *ce; \
-- s = '\0'; \
-+ s = NULL; \
- _convertType_ tempVal = _convertFunc_(buf, &ce, 0); \
- \
- if (ce != s) \
-@@ -273,7 +273,7 @@
- gotAll: \
- \
- char *ce; \
-- s = '\0'; \
-+ s = NULL; \
- double tempVal = _convertFunc_(buf, &ce); \
- \
- if (ce != s) \
diff --git a/media-libs/coin/files/coin-3.1.3-memhandler-initialization.patch b/media-libs/coin/files/coin-3.1.3-memhandler-initialization.patch
deleted file mode 100644
index 892882b6a3db..000000000000
--- a/media-libs/coin/files/coin-3.1.3-memhandler-initialization.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=619378
-Patch http://pkgs.fedoraproject.org/cgit/rpms/Coin3.git/tree/0012-memhandler-initialization.patch?id=ca89ec7227943bdec800ee51b920f578fab87b05
-
---- a/src/misc/SbHash.h
-+++ b/src/misc/SbHash.h
-@@ -89,6 +89,8 @@
- cc_memalloc_deallocate(entry->memhandler, ptr);
- }
- SbHashEntry(const Key & key, const Type & obj) : key(key), obj(obj) {}
-+ SbHashEntry(const Key & key, const Type & obj, cc_memalloc *memhandler)
-+ : key(key), obj(obj), memhandler(memhandler) {}
-
- Key key;
- Type obj;
-@@ -218,7 +220,7 @@
- /* Key not already in the hash table; insert a new
- * entry as the first element in the bucket
- */
-- entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj);
-+ entry = new (this->memhandler) SbHashEntry<Type, Key>(key, obj, this->memhandler);
- entry->next = this->buckets[i];
- this->buckets[i] = entry;
-
diff --git a/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch b/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch
deleted file mode 100644
index 3fd3bca726d4..000000000000
--- a/media-libs/coin/files/coin-3.1.3-pkgconfig-partial.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ru ../Coin-3.1.3/Coin.pc.in ./Coin.pc.in
---- Coin.pc.in 2010-03-02 14:20:09.000000000 +0100
-+++ Coin.pc.in 2010-06-28 19:27:59.634534460 +0200
-@@ -10,7 +10,8 @@
- Version: @COIN_VERSION@
- Requires:
- Conflicts:
--Libs: -L${libdir} @COIN_EXTRA_LDFLAGS@ @COIN_EXTRA_LIBS@
-+Libs: -L${libdir} -lCoin
-+Libs.private: -L${libdir} @COIN_EXTRA_LIBS@
- Cflags: -I${includedir} @COIN_EXTRA_CFLAGS@ @COIN_EXTRA_CPPFLAGS@
-
- coin_host=@host@
diff --git a/media-libs/coin/metadata.xml b/media-libs/coin/metadata.xml
index 11c05aeb8175..f76f33813aaf 100644
--- a/media-libs/coin/metadata.xml
+++ b/media-libs/coin/metadata.xml
@@ -8,9 +8,8 @@
<flag name="exceptions">Compile with C++ exceptions</flag>
<flag name="man">Build and install man pages</flag>
<flag name="qthelp">Build API documentation in QtHelp format</flag>
- <flag name="simage">Texture loading via <pkg>media-libs/simage</pkg> library</flag>
</use>
<upstream>
- <remote-id type="bitbucket">Coin3D/coin</remote-id>
+ <remote-id type="github">coin3d/coin</remote-id>
</upstream>
</pkgmetadata>