summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/ctl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/ctl')
-rw-r--r--media-libs/ctl/Manifest1
-rw-r--r--media-libs/ctl/ctl-1.4.1.ebuild35
-rw-r--r--media-libs/ctl/files/ctl-1.4.1-gcc43.patch106
-rw-r--r--media-libs/ctl/files/ctl-1.4.1-gcc47.patch15
-rw-r--r--media-libs/ctl/metadata.xml11
5 files changed, 168 insertions, 0 deletions
diff --git a/media-libs/ctl/Manifest b/media-libs/ctl/Manifest
new file mode 100644
index 000000000000..fe214663e075
--- /dev/null
+++ b/media-libs/ctl/Manifest
@@ -0,0 +1 @@
+DIST ctl-1.4.1.tar.gz 996923 SHA256 b202d9552eeb81f3ded66a6786719f6e1138fa4e31c866799b1efad6ef7a9f9a SHA512 671efbdef287c69b416462d479be58c6cfba331b5b6faa1a694ece162aa2ee966482423babb49c61de3d5046499a81110e4cd30824d9d36a3d6b69068b075063 WHIRLPOOL 2d5a928171cc842558b2c835419bf61da3293a1e6332bd53045ee65367ac67f69c82fea7285239419ed8e0b6256615c41a4f9a0dab52f120ca8504af3158814c
diff --git a/media-libs/ctl/ctl-1.4.1.ebuild b/media-libs/ctl/ctl-1.4.1.ebuild
new file mode 100644
index 000000000000..12fd88661702
--- /dev/null
+++ b/media-libs/ctl/ctl-1.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool
+
+DESCRIPTION="AMPAS' Color Transformation Language"
+HOMEPAGE="http://sourceforge.net/projects/ampasctl"
+SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="media-libs/ilmbase:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4{3,7}.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ prune_libtool_files --all
+}
diff --git a/media-libs/ctl/files/ctl-1.4.1-gcc43.patch b/media-libs/ctl/files/ctl-1.4.1-gcc43.patch
new file mode 100644
index 000000000000..5f7e8fa8d560
--- /dev/null
+++ b/media-libs/ctl/files/ctl-1.4.1-gcc43.patch
@@ -0,0 +1,106 @@
+--- IlmCtl/CtlLex.h
++++ IlmCtl/CtlLex.h
+@@ -58,10 +58,11 @@
+ //-----------------------------------------------------------------------------
+
+ #include <CtlLContext.h>
+ #include <CtlTokens.h>
+ #include <string>
++#include <cstdlib>
+
+ namespace Ctl {
+
+
+ class Lex
+--- IlmCtlMathTest/testAffineRec.cpp
++++ IlmCtlMathTest/testAffineRec.cpp
+@@ -43,13 +43,14 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
+-#include <string>
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+ #include <assert.h>
+ #include <CtlRbfInterpolator.h>
+ #include <ImathVec.h>
+
+ using namespace std;
+--- IlmCtlMathTest/testGaussRec.cpp
++++ IlmCtlMathTest/testGaussRec.cpp
+@@ -43,13 +43,14 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
+-#include <string>
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+ #include <assert.h>
+ #include <CtlRbfInterpolator.h>
+ #include <ImathVec.h>
+
+ using namespace std;
+--- IlmCtlSimd/CtlSimdReg.h
++++ IlmCtlSimd/CtlSimdReg.h
+@@ -50,10 +50,11 @@
+ #define INCLUDED_CTL_SIMD_REG_H
+
+ #include <typeinfo>
+ #include <CtlExc.h>
+ #include <Iex.h>
++#include <cstring>
+
+ //-----------------------------------------------------------------------------
+ //
+ // Registers for the SIMD color transformation engine
+ //
+--- IlmCtlTest/testExamples.cpp
++++ IlmCtlTest/testExamples.cpp
+@@ -43,10 +43,11 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
++#include <cstring>
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <assert.h>
+
+--- IlmCtlTest/testVarying.cpp
++++ IlmCtlTest/testVarying.cpp
+@@ -49,10 +49,11 @@
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <ImathMath.h>
+ #include <iostream>
++#include <cstring>
+ #include <exception>
+ #include <assert.h>
+ #include <sstream>
+ #include <limits>
+ #include <half.h>
+--- IlmCtlTest/testVaryingReturn.cpp
++++ IlmCtlTest/testVaryingReturn.cpp
+@@ -49,10 +49,11 @@
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <ImathMath.h>
+ #include <iostream>
++#include <cstring>
+ #include <exception>
+ #include <assert.h>
+ #include <sstream>
+ #include <limits>
+ #include <half.h>
diff --git a/media-libs/ctl/files/ctl-1.4.1-gcc47.patch b/media-libs/ctl/files/ctl-1.4.1-gcc47.patch
new file mode 100644
index 000000000000..1aa4be4fe6d0
--- /dev/null
+++ b/media-libs/ctl/files/ctl-1.4.1-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/426368
+
+ IlmCtl/CtlInterpreter.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/IlmCtl/CtlInterpreter.cpp
++++ b/IlmCtl/CtlInterpreter.cpp
+@@ -64,6 +64,7 @@
+ #include <fstream>
+ #include <algorithm>
+ #include <cassert>
++#include <unistd.h>
+
+ #ifdef WIN32
+ #include <io.h>
diff --git a/media-libs/ctl/metadata.xml b/media-libs/ctl/metadata.xml
new file mode 100644
index 000000000000..de95417e2be2
--- /dev/null
+++ b/media-libs/ctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ampasctl</remote-id>
+ </upstream>
+</pkgmetadata>