summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/evas/evas-1.7.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/evas/evas-1.7.10.ebuild')
-rw-r--r--media-libs/evas/evas-1.7.10.ebuild162
1 files changed, 162 insertions, 0 deletions
diff --git a/media-libs/evas/evas-1.7.10.ebuild b/media-libs/evas/evas-1.7.10.ebuild
new file mode 100644
index 000000000000..1a922dee35ce
--- /dev/null
+++ b/media-libs/evas/evas-1.7.10.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="hardware-accelerated retained canvas API"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Evas"
+
+LICENSE="BSD-2"
+IUSE="altivec bidi +bmp directfb +eet fbcon +fontconfig gles gif +ico +jpeg cpu_flags_x86_mmx opengl +png +ppm +psd cpu_flags_x86_sse cpu_flags_x86_sse3 static-libs tga tiff wayland X xcb xpm"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ >=media-libs/freetype-2.3.9
+ fontconfig? ( media-libs/fontconfig )
+ gles? ( media-libs/mesa[gallium,gles2] )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng:0= )
+ bidi? ( >=dev-libs/fribidi-0.19.1 )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ tiff? ( media-libs/tiff )
+ wayland? ( dev-libs/wayland )
+ xpm? ( x11-libs/libXpm )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ )
+ !X? (
+ xcb? (
+ x11-libs/xcb-util
+ ) )
+ eet? ( >=dev-libs/eet-${PV} )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ if use X ; then
+ if use xcb ; then
+ ewarn "You have enabled both 'X' and 'xcb', so we will use"
+ ewarn "X as it's considered the most stable for evas"
+ fi
+ E_ECONF+=(
+ --disable-software-xcb
+ $(use_enable opengl gl-xlib)
+ )
+ elif use xcb ; then
+ E_ECONF+=(
+ --disable-gl-xlib
+ --enable-software-xcb
+ $(use_enable opengl gl-xcb)
+ )
+ else
+ E_ECONF+=(
+ --disable-gl-xlib
+ --disable-software-xcb
+ --disable-gl-xcb
+ )
+ fi
+ if use wayland ; then
+ E_ECONF+=(
+ --enable-wayland-shm
+ )
+ if use gles ; then
+ E_ECONF+=(
+ --enable-wayland-egl
+ )
+ else
+ E_ECONF+=(
+ --disable-wayland-egl
+ )
+ fi
+ else
+ E_ECONF+=(
+ --disable-wayland-egl
+ --disable-wayland-shm
+ )
+ fi
+
+ E_ECONF+=(
+ $(use_enable altivec cpu-altivec)
+ $(use_enable bidi fribidi)
+ $(use_enable bmp image-loader-bmp)
+ $(use_enable bmp image-loader-wbmp)
+ $(use_enable directfb)
+ $(use_enable doc)
+ $(use_enable eet font-loader-eet)
+ $(use_enable eet image-loader-eet)
+ $(use_enable fbcon fb)
+ $(use_enable fontconfig)
+ $(use_enable gles gl-flavor-gles)
+ $(use_enable gles gles-variety-sgx)
+ $(use_enable gif image-loader-gif)
+ $(use_enable ico image-loader-ico)
+ $(use_enable jpeg image-loader-jpeg)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable png image-loader-png)
+ $(use_enable ppm image-loader-pmaps)
+ $(use_enable psd image-loader-psd)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse3 cpu-sse3)
+ --disable-image-loader-svg
+ $(use_enable tga image-loader-tga)
+ $(use_enable tiff image-loader-tiff)
+ --enable-pthreads
+ --enable-async-events
+ --enable-async-preload
+ $(use_enable X software-xlib)
+ $(use_enable xpm image-loader-xpm)
+ --enable-evas-magic-debug
+ --enable-static-software-generic
+ --enable-buffer
+ --enable-cpu-c
+ --enable-scale-sample
+ --enable-scale-smooth
+ --enable-convert-8-rgb-332
+ --enable-convert-8-rgb-666
+ --enable-convert-8-rgb-232
+ --enable-convert-8-rgb-222
+ --enable-convert-8-rgb-221
+ --enable-convert-8-rgb-121
+ --enable-convert-8-rgb-111
+ --enable-convert-16-rgb-565
+ --enable-convert-16-rgb-555
+ --enable-convert-16-rgb-444
+ --enable-convert-16-rgb-rot-0
+ --enable-convert-16-rgb-rot-270
+ --enable-convert-16-rgb-rot-90
+ --enable-convert-24-rgb-888
+ --enable-convert-24-bgr-888
+ --enable-convert-32-rgb-8888
+ --enable-convert-32-rgbx-8888
+ --enable-convert-32-bgr-8888
+ --enable-convert-32-bgrx-8888
+ --enable-convert-32-rgb-rot-0
+ --enable-convert-32-rgb-rot-270
+ --enable-convert-32-rgb-rot-90
+ --enable-image-loader-generic
+ --disable-harfbuzz
+ --disable-image-loader-edb
+ --disable-static-software-16
+ --disable-software-16-x11
+ )
+
+ enlightenment_src_configure
+}
+
+pkg_postinst() {
+ elog "for svg support install media-plugins/evas_generic_loaders[svg]"
+}