summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-03-25 23:21:23 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-03-25 23:32:58 +0200
commitb566633d73ffee4a83dd4ed6cf2c411a297b3763 (patch)
tree3a754dcc49d1cd12f8565496db3ebb547f35ddbf /media-libs/exempi/exempi-2.4.5.ebuild
parentsys-power/upower: fix XDG_* env variables related sandbox issues (diff)
downloadgentoo-b566633d73ffee4a83dd4ed6cf2c411a297b3763.tar.gz
gentoo-b566633d73ffee4a83dd4ed6cf2c411a297b3763.tar.bz2
gentoo-b566633d73ffee4a83dd4ed6cf2c411a297b3763.zip
media-libs/exempi: version bump to 2.4.5 fixing multiple security issues
Bug: https://bugs.gentoo.org/649950 Bug: https://bugs.gentoo.org/650714 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/exempi/exempi-2.4.5.ebuild')
-rw-r--r--media-libs/exempi/exempi-2.4.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/exempi/exempi-2.4.5.ebuild b/media-libs/exempi/exempi-2.4.5.ebuild
new file mode 100644
index 000000000000..2782b8b68f3c
--- /dev/null
+++ b/media-libs/exempi/exempi-2.4.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools ltprune
+
+DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ virtual/libiconv
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ test? ( >=dev-libs/boost-1.48 )
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+ cp /usr/share/gettext/config.rpath . || die
+ eautoreconf
+}
+
+src_configure() {
+ # Valgrind detection is "disabled" due to bug #295875
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm samples/{,source,testfiles}/Makefile* || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}