summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-26 22:13:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-26 22:14:06 +0200
commit28ed452f4ad9a6a5ee8a1edd31bf8d68834a7b06 (patch)
treef631843a407cdfe571e45417aa670dfdf55220d8 /media-libs/faad2/faad2-2.9.0.ebuild
parentdev-qt/qt-creator: add 4.10.1 (diff)
downloadgentoo-28ed452f4ad9a6a5ee8a1edd31bf8d68834a7b06.tar.gz
gentoo-28ed452f4ad9a6a5ee8a1edd31bf8d68834a7b06.tar.bz2
gentoo-28ed452f4ad9a6a5ee8a1edd31bf8d68834a7b06.zip
media-libs/faad2: bump to v2.9.0
Bug: https://bugs.gentoo.org/695540 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/faad2/faad2-2.9.0.ebuild')
-rw-r--r--media-libs/faad2/faad2-2.9.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/faad2/faad2-2.9.0.ebuild b/media-libs/faad2/faad2-2.9.0.ebuild
new file mode 100644
index 000000000000..6efca3713ab6
--- /dev/null
+++ b/media-libs/faad2/faad2-2.9.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+MY_PV=$(ver_rs 1- _)
+
+DESCRIPTION="AAC audio decoding library"
+HOMEPAGE="https://www.audiocoding.com/faad2.html"
+SRC_URI="https://github.com/knik0/faad2/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="digitalradio static-libs"
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:iquote :I:' libfaad/Makefile.am || die
+
+ # bug 466986
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --without-xmms
+ $(use_with digitalradio drm)
+ $(use_enable static-libs static)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ # do not build the frontend for non default abis
+ if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ sed -i -e 's/frontend//' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ einstalldocs
+}