summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-05 03:57:04 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-09 20:21:53 +0800
commit85ace4e0690d543746149b6be3705eac06f54dcb (patch)
treea9136648493044b4f302b19e2ffdcf780d24643e /media-libs/ffmpegsource/ffmpegsource-9999.ebuild
parentapp-text/linuxdoc-tools: remove old (diff)
downloadgentoo-85ace4e0690d543746149b6be3705eac06f54dcb.tar.gz
gentoo-85ace4e0690d543746149b6be3705eac06f54dcb.tar.bz2
gentoo-85ace4e0690d543746149b6be3705eac06f54dcb.zip
media-libs/ffmpegsource: update live ebuild
Bump EAPI to 6, drop unused static-libs USE. Closes: https://github.com/gentoo/gentoo/pull/1439 Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'media-libs/ffmpegsource/ffmpegsource-9999.ebuild')
-rw-r--r--media-libs/ffmpegsource/ffmpegsource-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/media-libs/ffmpegsource/ffmpegsource-9999.ebuild b/media-libs/ffmpegsource/ffmpegsource-9999.ebuild
index f057f8af1935..8e2ad6a8e77a 100644
--- a/media-libs/ffmpegsource/ffmpegsource-9999.ebuild
+++ b/media-libs/ffmpegsource/ffmpegsource-9999.ebuild
@@ -2,20 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils flag-o-matic git-r3
+inherit autotools eutils flag-o-matic git-r3
DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
HOMEPAGE="https://github.com/FFMS/ffms2"
-EGIT_REPO_URI="https://github.com/FFMS/ffms2.git"
+EGIT_REPO_URI="git://github.com/FFMS/ffms2.git"
LICENSE="MIT"
SLOT="0/4"
KEYWORDS=""
-IUSE="libav static-libs"
+IUSE="libav"
RDEPEND="
sys-libs/zlib
@@ -31,3 +29,13 @@ pkg_pretend() {
die "Your compiler lacks C++11 support. Use GCC>=4.7.0 or Clang>=3.3."
fi
}
+
+src_prepare() {
+ default_src_prepare
+ eautoreconf
+}
+
+src_install() {
+ default_src_install
+ prune_libtool_files --modules
+}