summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/fidlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/fidlib')
-rw-r--r--media-libs/fidlib/Manifest1
-rw-r--r--media-libs/fidlib/fidlib-0.9.10-r1.ebuild49
-rw-r--r--media-libs/fidlib/fidlib-0.9.10.ebuild50
-rw-r--r--media-libs/fidlib/files/fidlib-0.9.10-cpp-extern.patch21
-rw-r--r--media-libs/fidlib/files/fidlib-0.9.10-extern.patch26
-rw-r--r--media-libs/fidlib/metadata.xml5
6 files changed, 152 insertions, 0 deletions
diff --git a/media-libs/fidlib/Manifest b/media-libs/fidlib/Manifest
new file mode 100644
index 000000000000..39f06eb3a043
--- /dev/null
+++ b/media-libs/fidlib/Manifest
@@ -0,0 +1 @@
+DIST fidlib-0.9.10.tgz 87082 SHA256 14ab5d50798d6b24f6421a21813de533f7b62b78c46978bbd0f499f33c21733e SHA512 77600acd665407b4d786b406a4f20b2f6c30c74775f5777d5054420b80c74e5bfa316bf7bd90df1669c09cef0ff9b552a0338cd138bf7d9bcf1df7cbff9fea4b WHIRLPOOL c8613f29e8b67b9da6b424759ede6141bb844f3e6b65abc7d9d2cc3b3cff7fac3c5110f7f092ba68b24b47e258789e18a1baeb5ef253033c276808605d9199e2
diff --git a/media-libs/fidlib/fidlib-0.9.10-r1.ebuild b/media-libs/fidlib/fidlib-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..a76d0f732617
--- /dev/null
+++ b/media-libs/fidlib/fidlib-0.9.10-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic eutils multilib
+
+DESCRIPTION="Run-time filter design and execution library"
+HOMEPAGE="http://uazu.net/fidlib/"
+SRC_URI="http://uazu.net/fidlib/${P}.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-extern.patch
+
+ # Avoid ICE under gcc-4.6, fixed in 4.6.3
+ if [[ $(gcc-version) == "4.6" && $(gcc-micro-version) -le 2 ]] ; then
+ replace-flags -O? -O0
+ fi
+}
+
+src_compile() {
+ # build library
+ doecho $(tc-getCC) ${CFLAGS} -DT_LINUX ${LDFLAGS} -Wl,-soname,libfidlib.so.${PV:0:1} \
+ -fPIC -shared fidlib.c -lm -o libfidlib.so.${PV:0:1}
+
+ # build command-line tool
+ doecho $(tc-getCC) ${CFLAGS} ${LDFLAGS} firun.c -lm ./libfidlib.so.${PV:0:1} -o firun
+}
+
+src_install() {
+ dobin firun
+ dolib.so libfidlib.so.${PV:0:1}
+ dosym libfidlib.so.${PV:0:1} /usr/$(get_libdir)/libfidlib.so
+
+ insinto /usr/include/fidlib
+ doins fidlib.h
+
+ dodoc NEWS README fidlib.txt firun.txt
+}
diff --git a/media-libs/fidlib/fidlib-0.9.10.ebuild b/media-libs/fidlib/fidlib-0.9.10.ebuild
new file mode 100644
index 000000000000..7fdca895fb1f
--- /dev/null
+++ b/media-libs/fidlib/fidlib-0.9.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic eutils multilib
+
+DESCRIPTION="Run-time filter design and execution library"
+HOMEPAGE="http://uazu.net/fidlib/"
+SRC_URI="http://uazu.net/fidlib/${P}.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cpp-extern.patch
+
+ # Avoid ICE under gcc-4.6, fixed in 4.6.3
+ if [[ $(gcc-version) == "4.6" && $(gcc-micro-version) -le 2 ]] ; then
+ replace-flags -O? -O0
+ fi
+}
+
+src_compile() {
+ # build library
+ doecho $(tc-getCC) ${CFLAGS} -DT_LINUX ${LDFLAGS} -Wl,-soname,libfidlib.so.${PV:0:1} \
+ -fPIC -shared fidlib.c -lm -o libfidlib.so.${PV:0:1}
+
+ # build command-line tool
+ doecho $(tc-getCC) ${CFLAGS} ${LDFLAGS} firun.c -lm ./libfidlib.so.${PV:0:1} -o firun
+}
+
+src_install() {
+ dobin firun
+ dolib.so libfidlib.so.${PV:0:1}
+ dosym libfidlib.so.${PV:0:1} /usr/$(get_libdir)/libfidlib.so
+
+ insinto /usr/include/fidlib
+ doins fidlib.h
+
+ dodoc NEWS README fidlib.txt firun.txt
+}
diff --git a/media-libs/fidlib/files/fidlib-0.9.10-cpp-extern.patch b/media-libs/fidlib/files/fidlib-0.9.10-cpp-extern.patch
new file mode 100644
index 000000000000..221ec825f174
--- /dev/null
+++ b/media-libs/fidlib/files/fidlib-0.9.10-cpp-extern.patch
@@ -0,0 +1,21 @@
+--- fidlib-0.9.10/fidlib.h
++++ fidlib-0.9.10/fidlib.h
+@@ -2,6 +2,10 @@
+ // fidlib include file
+ //
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ typedef struct FidFilter FidFilter;
+ struct FidFilter {
+ short typ; // Type of filter element 'I' IIR, 'F' FIR, or 0 for end of list
+@@ -66,3 +70,7 @@
+ extern void fid_run_zapbuf(void *buf);
+ extern void fid_run_freebuf(void *runbuf);
+ extern void fid_run_free(void *run);
++
++#ifdef __cplusplus
++}
++#endif
diff --git a/media-libs/fidlib/files/fidlib-0.9.10-extern.patch b/media-libs/fidlib/files/fidlib-0.9.10-extern.patch
new file mode 100644
index 000000000000..0e819942907e
--- /dev/null
+++ b/media-libs/fidlib/files/fidlib-0.9.10-extern.patch
@@ -0,0 +1,26 @@
+--- fidlib-0.9.10/fidlib.h
++++ fidlib-0.9.10/fidlib.h
+@@ -2,6 +2,13 @@
+ // fidlib include file
+ //
+
++#ifndef __FIDLIB_H
++#define __FIDLIB_H
++
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ typedef struct FidFilter FidFilter;
+ struct FidFilter {
+ short typ; // Type of filter element 'I' IIR, 'F' FIR, or 0 for end of list
+@@ -66,3 +73,9 @@
+ extern void fid_run_zapbuf(void *buf);
+ extern void fid_run_freebuf(void *runbuf);
+ extern void fid_run_free(void *run);
++
++#ifdef __cplusplus
++}
++#endif
++
++#endif /* __FIDLIB_H */
diff --git a/media-libs/fidlib/metadata.xml b/media-libs/fidlib/metadata.xml
new file mode 100644
index 000000000000..af0275e2998a
--- /dev/null
+++ b/media-libs/fidlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+</pkgmetadata>