summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/flickcurl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/flickcurl')
-rw-r--r--media-libs/flickcurl/Manifest3
-rw-r--r--media-libs/flickcurl/flickcurl-1.24.ebuild45
-rw-r--r--media-libs/flickcurl/flickcurl-1.25.ebuild45
-rw-r--r--media-libs/flickcurl/flickcurl-1.26.ebuild45
-rw-r--r--media-libs/flickcurl/metadata.xml8
5 files changed, 146 insertions, 0 deletions
diff --git a/media-libs/flickcurl/Manifest b/media-libs/flickcurl/Manifest
new file mode 100644
index 000000000000..ebf023235b2e
--- /dev/null
+++ b/media-libs/flickcurl/Manifest
@@ -0,0 +1,3 @@
+DIST flickcurl-1.24.tar.gz 1852406 SHA256 61f1a908ae2342490218dd9b435fc408bc5d22ce5f046c7cf9f742cab68502a8 SHA512 6749ca59b21f5919f817edee37a89e4996493f4ad4165d6131d267b0de282202a8e531f7350b19f54c83ca97c730baab94b9cf144f076ab19a04705062b229cd WHIRLPOOL 59d0d7076d9216aa92bacd5da0fda18e906f6f526060f578600e758f2c0cd417d3fa64a26dfdb2cbea0c37a9a5c0d8bbeabb236968c1df2c45f15a0e565f9244
+DIST flickcurl-1.25.tar.gz 1856658 SHA256 4ce95b659da2ea790b7244baa441d59eef1db794778491f6d709b784517d560b SHA512 51a449f52ba780cf6dd914e249012e338865af3a10a63c1c1efd611d0064acd117f9e8a8cc63edba93c3ce81b52c1c5586df52079644dc717be591542ad9dd7f WHIRLPOOL b8e8a4037a556fa8561618f2582ed35eae4d20a31603363d765c52bb4f08de6dff9dfef9c5845c290e29fd70a2aeacad5d1b858b31e037d632c2c9414bb3ed44
+DIST flickcurl-1.26.tar.gz 1870073 SHA256 ff42a36c7c1c7d368246f6bc9b7d792ed298348e5f0f5d432e49f6803562f5a3 SHA512 5ffdef58e67cbf99da2e8eefad57e845627703d5b22c85d5635557cd2df53e47e74d8e3387523495708c5cc8952c290da5c4d5f1e86bd482312fc7e46e9af6cd WHIRLPOOL 3bf5557eccdaca91077a13e01ea6cb3bbc068427b143a2eadfc0aa536e5945e2d0bd636ff4ae4d27ea23dbb8fd8614049dd48f2a7f9c7fa595125c1b0af4ca61
diff --git a/media-libs/flickcurl/flickcurl-1.24.ebuild b/media-libs/flickcurl/flickcurl-1.24.ebuild
new file mode 100644
index 000000000000..830b7a581c0a
--- /dev/null
+++ b/media-libs/flickcurl/flickcurl-1.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="C library for the Flickr API"
+HOMEPAGE="http://librdf.org/flickcurl/"
+SRC_URI="http://download.dajobe.org/flickcurl/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc raptor static-libs"
+
+RDEPEND=">=net-misc/curl-7.10.0
+ >=dev-libs/libxml2-2.6.8:2
+ raptor? ( media-libs/raptor:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use doc ; then
+ # Only install html documentation when the use flag is enabled
+ sed -e '/gtk-doc.make/d' \
+ -e 's:+=:=:' \
+ -i docs/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with raptor) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" TARGET_DIR=/usr/share/doc/${PF}/html install
+ dodoc AUTHORS ChangeLog NEWS README
+ prune_libtool_files
+}
diff --git a/media-libs/flickcurl/flickcurl-1.25.ebuild b/media-libs/flickcurl/flickcurl-1.25.ebuild
new file mode 100644
index 000000000000..95c94f889882
--- /dev/null
+++ b/media-libs/flickcurl/flickcurl-1.25.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="C library for the Flickr API"
+HOMEPAGE="http://librdf.org/flickcurl/"
+SRC_URI="http://download.dajobe.org/flickcurl/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc raptor static-libs"
+
+RDEPEND=">=net-misc/curl-7.10.0
+ >=dev-libs/libxml2-2.6.8:2
+ raptor? ( media-libs/raptor:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use doc ; then
+ # Only install html documentation when the use flag is enabled
+ sed -e '/gtk-doc.make/d' \
+ -e 's:+=:=:' \
+ -i docs/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with raptor) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" TARGET_DIR=/usr/share/doc/${PF}/html install
+ dodoc AUTHORS ChangeLog NEWS README
+ prune_libtool_files
+}
diff --git a/media-libs/flickcurl/flickcurl-1.26.ebuild b/media-libs/flickcurl/flickcurl-1.26.ebuild
new file mode 100644
index 000000000000..779af1c9578e
--- /dev/null
+++ b/media-libs/flickcurl/flickcurl-1.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="C library for the Flickr API"
+HOMEPAGE="http://librdf.org/flickcurl/"
+SRC_URI="http://download.dajobe.org/flickcurl/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc raptor static-libs"
+
+RDEPEND=">=net-misc/curl-7.10.0
+ >=dev-libs/libxml2-2.6.8:2
+ raptor? ( media-libs/raptor:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use doc ; then
+ # Only install html documentation when the use flag is enabled
+ sed -e '/gtk-doc.make/d' \
+ -e 's:+=:=:' \
+ -i docs/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with raptor) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" TARGET_DIR=/usr/share/doc/${PF}/html install
+ dodoc AUTHORS ChangeLog NEWS README
+ prune_libtool_files
+}
diff --git a/media-libs/flickcurl/metadata.xml b/media-libs/flickcurl/metadata.xml
new file mode 100644
index 000000000000..bbe3ae036794
--- /dev/null
+++ b/media-libs/flickcurl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <use>
+ <flag name="raptor">Use <pkg>media-libs/raptor</pkg> for proper RDF serializing</flag>
+ </use>
+</pkgmetadata>