summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-27 12:36:24 -0700
committerMatt Turner <mattst88@gentoo.org>2019-03-27 12:54:01 -0700
commit27083133bfb71b4fe269d35b4158e553859d81fe (patch)
tree162a03f1714836023a8c4f1483c968713f7e7687 /media-libs/freeglut
parentapp-text/docbook-xml-dtd: marked ~sparc64-solaris (diff)
downloadgentoo-27083133bfb71b4fe269d35b4158e553859d81fe.tar.gz
gentoo-27083133bfb71b4fe269d35b4158e553859d81fe.tar.bz2
gentoo-27083133bfb71b4fe269d35b4158e553859d81fe.zip
media-libs/freeglut: Drop linking with unnecessary X11 libs
Many thanks go to Christian <christian@ch-sc.de> for tracking down and fixing the bug! Closes: https://bugs.gentoo.org/557286 Closes: https://bugs.gentoo.org/647326 Closes: https://bugs.gentoo.org/658936 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/freeglut')
-rw-r--r--media-libs/freeglut/files/freeglut-3.0.0-drop-unnecessary-x11-libs.patch30
-rw-r--r--media-libs/freeglut/freeglut-3.0.0.ebuild4
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/freeglut/files/freeglut-3.0.0-drop-unnecessary-x11-libs.patch b/media-libs/freeglut/files/freeglut-3.0.0-drop-unnecessary-x11-libs.patch
new file mode 100644
index 000000000000..761a6bfce7c2
--- /dev/null
+++ b/media-libs/freeglut/files/freeglut-3.0.0-drop-unnecessary-x11-libs.patch
@@ -0,0 +1,30 @@
+From bbdaa724ef363e34bd19fb2308739e59a9e8ddc8 Mon Sep 17 00:00:00 2001
+From: jtsiomb <jtsiomb@7f0cb862-5218-0410-a997-914c9d46530a>
+Date: Tue, 26 Mar 2019 18:55:42 +0000
+Subject: [PATCH] Applied Christian's change to drop unnecessary dependency to
+ X11 libraries we don't actually use, by asking cmake to link with X11_X11_LIB
+ instead of the catch-all X11_LIBRARIES.
+
+git-svn-id: http://svn.code.sf.net/p/freeglut/code/trunk/freeglut/freeglut@1845 7f0cb862-5218-0410-a997-914c9d46530a
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d1c20e8..e324a02 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -312,8 +312,8 @@ ENDIF(CMAKE_COMPILER_IS_GNUCC)
+ INCLUDE(CheckIncludeFiles)
+ IF(UNIX AND NOT(ANDROID OR BLACKBERRY OR FREEGLUT_WAYLAND))
+ FIND_PACKAGE(X11 REQUIRED)
+- INCLUDE_DIRECTORIES(${X11_INCLUDE_DIR})
+- LIST(APPEND LIBS ${X11_LIBRARIES})
++ INCLUDE_DIRECTORIES(${X11_X11_INCLUDE_PATH})
++ LIST(APPEND LIBS ${X11_X11_LIB})
+ IF(X11_Xrandr_FOUND)
+ SET(HAVE_X11_EXTENSIONS_XRANDR_H TRUE)
+ LIST(APPEND LIBS ${X11_Xrandr_LIB})
+--
+2.19.2
+
diff --git a/media-libs/freeglut/freeglut-3.0.0.ebuild b/media-libs/freeglut/freeglut-3.0.0.ebuild
index 2a60b23ef112..95ec4c4bca87 100644
--- a/media-libs/freeglut/freeglut-3.0.0.ebuild
+++ b/media-libs/freeglut/freeglut-3.0.0.ebuild
@@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
HTML_DOCS=( doc/. )
+PATCHES=(
+ "${FILESDIR}"/${P}-drop-unnecessary-x11-libs.patch
+)
+
src_configure() {
local mycmakeargs=(
"-DFREEGLUT_GLES=OFF"