summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-20 12:19:57 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-20 12:19:57 +0100
commit77d4d6c310eb41f9a52bbaeb464b300fff6a916f (patch)
treee40d42789cfdf150f5dae03aadebcb972aa2c9dc /media-libs/ganv
parentmedia-sound/jalv: bump 1.6.4 (diff)
downloadgentoo-77d4d6c310eb41f9a52bbaeb464b300fff6a916f.tar.gz
gentoo-77d4d6c310eb41f9a52bbaeb464b300fff6a916f.tar.bz2
gentoo-77d4d6c310eb41f9a52bbaeb464b300fff6a916f.zip
media-libs/ganv: update
1) rebased patch 2) eapi6 3) added missing dep (bug #668592) Closes: https://bugs.gentoo.org/668592 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/ganv')
-rw-r--r--media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch12
-rw-r--r--media-libs/ganv/ganv-1.4.2-r1.ebuild (renamed from media-libs/ganv/ganv-1.4.2.ebuild)12
2 files changed, 13 insertions, 11 deletions
diff --git a/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch b/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
index 17cc2432d0ec..3fb29a7f0b54 100644
--- a/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
+++ b/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
@@ -1,8 +1,8 @@
-Index: src/Canvas.cpp
-===================================================================
---- src/Canvas.cpp (revision 5479)
-+++ src/Canvas.cpp (revision 5480)
-@@ -760,6 +760,18 @@
+diff --git a/src/Canvas.cpp b/src/Canvas.cpp
+index c01021c..1c66a6c 100644
+--- a/src/Canvas.cpp
++++ b/src/Canvas.cpp
+@@ -760,6 +760,18 @@ GanvCanvasImpl::layout_dot(const std::string& filename)
}
#endif
@@ -21,7 +21,7 @@ Index: src/Canvas.cpp
#ifdef GANV_FDGL
inline Region
-@@ -788,18 +800,6 @@
+@@ -788,18 +800,6 @@ apply_force(GanvNode* a, GanvNode* b, const Vector& f)
b->impl->force = vec_sub(b->impl->force, f);
}
diff --git a/media-libs/ganv/ganv-1.4.2.ebuild b/media-libs/ganv/ganv-1.4.2-r1.ebuild
index dafedc72ffda..3d19184be690 100644
--- a/media-libs/ganv/ganv-1.4.2.ebuild
+++ b/media-libs/ganv/ganv-1.4.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+# oes not work with python3
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
inherit eutils flag-o-matic waf-utils python-any-r1
@@ -26,12 +27,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
+ dev-util/glib-utils
nls? ( virtual/libintl )
"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-no-fdgl.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-no-fdgl.patch
+)
src_configure() {
append-cxxflags -std=c++11