summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-18 22:47:06 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-18 22:47:37 -0500
commit00d483b9e0a95a670bed0ec3b97e2adf16afb0c4 (patch)
treecf17171040dda5d1a6e65e0e7ee1ba4c1f9ce38b /media-libs/glfw
parentprofiles: reduce app-emulation/wine gstreamer mask to 1.7.54 only (diff)
downloadgentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.tar.gz
gentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.tar.bz2
gentoo-00d483b9e0a95a670bed0ec3b97e2adf16afb0c4.zip
media-libs/glfw: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/glfw')
-rw-r--r--media-libs/glfw/Manifest1
-rw-r--r--media-libs/glfw/glfw-3.1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index a5d494d8caf6..e9c282a6966a 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1,2 +1,3 @@
DIST glfw-2.7.7.tar.bz2 927805 SHA256 422e755979524a1da28e4addcae723b7132998ca15e89be41bf34964d9360aa2 SHA512 1b51b9d88c8eed9da8084421949b561a4779410a6369ffdf482c2d8a166bab8c58bbb087ef6f32180d3fe9430988549be5c183b338dd0e1191b2c4b4a7b55379 WHIRLPOOL 646d38fd3ea88e8aa19dcbfa8f8b933adc530ea946cd51c3e03971ed6cdb294dadf5020a876ba298c378896179a4a7ba0129b858fc7f1273a574fe1c2c388a77
DIST glfw-3.1.1.tar.bz2 584344 SHA256 4a8516223c1df079efb398754f4533af7e943188ea9b5222e7f27c25e4822d61 SHA512 c54da5a1714aa1f9a79283922374672dac01c6a6093ed4cddd257d565258e6adffab83bcb34723cd34b415d9a8029f5f13fb225e6cf0a29bc74126a9bd5147e7 WHIRLPOOL d2ee39e01b3d6ff24af8fe5c262d4c099412eb42324726d8a0aa306d93fe6c6fe8477b6afd72e79122fc35258e573e87232128b193a461d7c7f8544338e292a5
+DIST glfw-3.1.2.tar.bz2 588640 SHA256 31a1e6b6d7c64bbf44dce623785c87c0f29d965b19c452828e48acd64fa643e7 SHA512 00dc822403848f3e60535b9f70ea43147717252373c704c52b5480020cea7f416a00c036ab5ffbc0bc76863c4ddb7d271310e64face639e68f7a62e9db882e94 WHIRLPOOL 1e54efff306fc7f17620f6a874c66e5315d9dd2b2c45f6f4c95562b1c2ac50c5e4410173c23351c31aeaee187b5fe39999d1788fd9a42053d420b5a252331a2c
diff --git a/media-libs/glfw/glfw-3.1.2.ebuild b/media-libs/glfw/glfw-3.1.2.ebuild
new file mode 100644
index 000000000000..1aa6935bcd78
--- /dev/null
+++ b/media-libs/glfw/glfw-3.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="http://www.glfw.org/"
+SRC_URI="mirror://sourceforge/glfw/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="egl examples"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ x11-libs/libXinerama
+ x11-libs/libXcursor
+ virtual/opengl"
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use egl GLFW_USE_EGL)
+ $(cmake-utils_use examples GLFW_BUILD_EXAMPLES)
+ -DBUILD_SHARED_LIBS=1
+ "
+ cmake-utils_src_configure
+}