summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-06-30 17:36:37 +0200
committerMarek Szuba <marecki@gentoo.org>2020-06-30 17:42:07 +0200
commit8dbd15d013e01918d907865b0ac1803a8ed21768 (patch)
tree7df575f28c10273cca97deb68222079b48175305 /media-libs/gmmlib
parentapp-backup/borgmatic: bump to 1.5.7 (diff)
downloadgentoo-8dbd15d013e01918d907865b0ac1803a8ed21768.tar.gz
gentoo-8dbd15d013e01918d907865b0ac1803a8ed21768.tar.bz2
gentoo-8dbd15d013e01918d907865b0ac1803a8ed21768.zip
media-libs/gmmlib: bump to 20.2.2
Now with test execution moved from src_compile to src_test and controlled by FEATURES=test. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-libs/gmmlib')
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch42
-rw-r--r--media-libs/gmmlib/gmmlib-20.2.2.ebuild46
3 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index 09ff77d0a201..f9dde767509e 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1,3 +1,4 @@
DIST intel-gmmlib-19.3.4.tar.gz 706943 BLAKE2B 12eef2d0bed76e94770295461935b4056f40dab97bb24acf8e700d2b83198bb8a2800ab9155aebba5138a3269d4aefe645390524d34e57706de750f8e967d106 SHA512 77c7cf1cd3e7f0c2476badca6ae7a36504afb4af5f2c2282e790744a9b8ef668f24c4db8be171eef02394966021b5647921c0faf710e26689cebbd879b786a9d
DIST intel-gmmlib-19.4.1.tar.gz 707375 BLAKE2B 0627889bebf763a8225c691e7ec6a2b3c1f403f62e5d11b557e3578e02b6cc3fe032e8b0d79483f34e9310bcfcd7667c407b1c4e549a2bb414247468b020f796 SHA512 264f111348bbaccd6c14c31ab15c7b02e63def56b0d3effa01067fb5e696d6d3e2ad3d5a9cc3a36f33b835dda12ec3916a31d3a812443de9d5dd815e2e4cde53
DIST intel-gmmlib-20.1.1.tar.gz 707814 BLAKE2B 49983345d0187114de6622522a1342f978f67347f210a0f5a67c847089268e9f6730f76f365c2e15160c538231f057be68ca3b1dd1c4c5deb0693ab7c94f54f7 SHA512 e16472f24c5d1fb9f56c45ce1aefe6b1799a2c968aab09808115eeb9deda9a7610da989ae2fdc1796d94d05ca09a19ab2e74be62b4192eeee70ead404561a03f
+DIST intel-gmmlib-20.2.2.tar.gz 728309 BLAKE2B 1c26661c5317d66797ca8a72fe910ae73a97c7bc3b5730b6c270daa3eac753287cd83334085c90ce081ff4a8a4d1f79b46e832059b08c36602c5c39f3b3a1af5 SHA512 ebd23658aec78ebdf7cd13577f5ca408e2995c4df6135c951d3bea4a59a84461690d71f6e7ebc2014daa5508e07d32ff20c25019d90255150e7c93e241d403fc
diff --git a/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch b/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
new file mode 100644
index 000000000000..7d826fabd0a7
--- /dev/null
+++ b/media-libs/gmmlib/files/gmmlib-20.2.2_conditional_testing.patch
@@ -0,0 +1,42 @@
+Makes the test suite run in src_test(), not src_compile(). Note that
+at the moment all the output from the test runner goes into the CTest log
+and all that src_test() shows is the overall status of the execution
+of the runner.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,8 +1,6 @@
+ cmake_minimum_required (VERSION 3.1 FATAL_ERROR)
+
+-if (NOT DEFINED RUN_TEST_SUITE)
+-option (RUN_TEST_SUITE "run test suite after install" ON)
+-endif (NOT DEFINED RUN_TEST_SUITE)
++include(CTest)
+
+ add_subdirectory(Source/GmmLib)
+
+--- a/Source/GmmLib/CMakeLists.txt
++++ b/Source/GmmLib/CMakeLists.txt
+@@ -495,7 +495,7 @@
+ _X64)
+ endif()
+
+-if(NOT DEFINED RUN_TEST_SUITE OR RUN_TEST_SUITE)
++if(BUILD_TESTING)
+ add_subdirectory(ULT)
+ endif()
+
+--- a/Source/GmmLib/ULT/CMakeLists.txt
++++ b/Source/GmmLib/ULT/CMakeLists.txt
+@@ -151,9 +151,7 @@
+
+ add_custom_target(Run_ULT ALL DEPENDS GMMULT)
+
+-add_custom_command(
+- TARGET Run_ULT
+- POST_BUILD
+- COMMAND echo running ULTs
++add_test(
++ NAME Run_ULT
+ COMMAND "${CMAKE_COMMAND}" -E env "LD_LIBRARY_PATH=$<TARGET_FILE_DIR:igfx_gmmumd_dll>" ${CMAKE_CFG_INTDIR}/${EXE_NAME} --gtest_filter=CTest*
+ )
diff --git a/media-libs/gmmlib/gmmlib-20.2.2.ebuild b/media-libs/gmmlib/gmmlib-20.2.2.ebuild
new file mode 100644
index 000000000000..2cb36edcb25f
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-20.2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}