summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-06-18 07:05:39 +0300
committerMart Raudsepp <leio@gentoo.org>2017-06-18 11:29:13 +0300
commit740d62549bfcc535056e42cfef0edb25c17216dd (patch)
treecc7d82a5390ed6d787a2a5e72642719933e7f613 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild
parentmedia-plugins/gst-plugins-ximagesrc: bump to 1.10.5, no code changes compared... (diff)
downloadgentoo-740d62549bfcc535056e42cfef0edb25c17216dd.tar.gz
gentoo-740d62549bfcc535056e42cfef0edb25c17216dd.tar.bz2
gentoo-740d62549bfcc535056e42cfef0edb25c17216dd.zip
media-libs/gst-plugins-ugly: bump to 1.10.5
Includes security patch from skipped 1.10.4, as we included it in 1.10.3 No other changes compared to 1.10.3 (a bug fix is in gst-plugins-mpeg2dec split)
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild
new file mode 100644
index 000000000000..c0c2dc6aaeed
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.10.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}