summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-09-18 23:39:33 +0300
committerMart Raudsepp <leio@gentoo.org>2017-09-18 23:39:34 +0300
commit49a264a3bfcc2ab185546642c3e59c5350b092e2 (patch)
tree9bbfb530963dd1d1b8fa9fae7e729c5ad6c40487 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild
parentmedia-libs/gstreamer: remove stale patch (diff)
downloadgentoo-49a264a3bfcc2ab185546642c3e59c5350b092e2.tar.gz
gentoo-49a264a3bfcc2ab185546642c3e59c5350b092e2.tar.bz2
gentoo-49a264a3bfcc2ab185546642c3e59c5350b092e2.zip
media-libs/gst-plugins-ugly: bump to 1.12.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild
new file mode 100644
index 000000000000..c0c2dc6aaeed
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}