summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 16:24:34 +0100
committerGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 16:54:19 +0100
commit7f744dee4a6e030e7b61b88d4f04990427bed0c7 (patch)
tree5ce6f5f89fbeb8534eee61b60525c22aa60a2594 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild
parentdev-lang/falcon: Drop old (diff)
downloadgentoo-7f744dee4a6e030e7b61b88d4f04990427bed0c7.tar.gz
gentoo-7f744dee4a6e030e7b61b88d4f04990427bed0c7.tar.bz2
gentoo-7f744dee4a6e030e7b61b88d4f04990427bed0c7.zip
media-libs/gst-plugins-ugly: version bump to 1.6.3
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild
new file mode 100644
index 000000000000..15e8d22b0720
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}