summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-11-02 11:16:36 +0530
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:12:28 +0000
commit99857f45011b1da80a5fc0ec73050dec67c65d35 (patch)
treeb65eb27a4f21bd0d77606696f383ff49c467bd9b /media-libs/gst-rtsp-server
parentpackage.mask: Stop last rite of media-libs/libvisual for now (diff)
downloadgentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.gz
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.bz2
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.zip
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.20.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index e2d8be0eab7d..4e48ce669288 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1 +1,2 @@
DIST gst-rtsp-server-1.20.3.tar.xz 362348 BLAKE2B 45d5ff58d76b9b83baa6e5956976e1fdc10dae3200d30a877a26ddafda4f919ecaeca85fceec6fb3b7802303d152087d3f5813f6e3bf36a941a0c46fceeb1292 SHA512 15baf83d77d57d1e2517feffad68b4508e7a959863b5e6fa3d0f564c81786df8d3c1e57d8b8a9f9b623e19212feb137dfe89d8e385f518c86f205c4461802007
+DIST gst-rtsp-server-1.20.4.tar.xz 366208 BLAKE2B 0fec083dd18a2979a311dc69b54a580520e27fb11e35e529d2e1be2823c130ce6b2d27a715d67617fe04d81641e31d7fe8e3f6c38a3e17c4d4acee1415f33d60 SHA512 85952e5d8febb1df1a558a55bb3840a9574f5cbb83e777072b556b96a62dfaf83ccc9e3ed38604f07b7ff797da2b609d7ed9422f3b01faaf783709c012803b9a
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.4.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.4.ebuild
new file mode 100644
index 000000000000..b48154a12921
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc "${S}"/examples/*.c
+ fi
+}