summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:06:52 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:12:27 +0100
commitfe58c96bd6f41daf6d49d926528ff4782d8f95a9 (patch)
tree1d25f60054f92f8dd3383523c4a8f085aa02da8b /media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild
parentmedia-plugins/gst-plugins-libav: version bump to 1.6.1 (diff)
downloadgentoo-fe58c96bd6f41daf6d49d926528ff4782d8f95a9.tar.gz
gentoo-fe58c96bd6f41daf6d49d926528ff4782d8f95a9.tar.bz2
gentoo-fe58c96bd6f41daf6d49d926528ff4782d8f95a9.zip
media-libs/gstreamer-editing-services: version bump to 1.6.1
Use ${PV} for gstreamer and gst-plugins-base dependency as all releases are coordinated for a while now. Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild')
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild
new file mode 100644
index 000000000000..3ffda41adfa6
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+# FIXME: There is something odd with pygobject check for >=4.22,
+# check with upstream
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gnonlin:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.3
+ virtual/pkgconfig
+"
+# XXX: tests do pass but need g-e-s to be installed due to missing
+# AM_TEST_ENVIRONMENT setup.
+RESTRICT="test"
+
+src_configure() {
+ # gtk is only used for examples
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-examples \
+ --without-gtk \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-package-name="GStreamer editing services ebuild for Gentoo" \
+ --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer-editing-services"
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #538888
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}