summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-03-17 17:15:55 +0100
committerSam James <sam@gentoo.org>2021-05-30 00:34:56 +0000
commit9ae534a9bce779381f3eee0bace18c06a7d2ab3d (patch)
treeb794a8190668764d62453c3e536df4ca92e9b24b /media-libs/gstreamer
parentgstreamer-meson.eclass: New eclass required for gstreamer-1.18.0+ (diff)
downloadgentoo-9ae534a9bce779381f3eee0bace18c06a7d2ab3d.tar.gz
gentoo-9ae534a9bce779381f3eee0bace18c06a7d2ab3d.tar.bz2
gentoo-9ae534a9bce779381f3eee0bace18c06a7d2ab3d.zip
media-libs/gstreamer: Version bump, 1.18.4
Closes: https://bugs.gentoo.org/756298 Bug: https://bugs.gentoo.org/756298 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.18.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index fd1723b35124..7d170d36e78b 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1 +1,2 @@
DIST gstreamer-1.16.3.tar.xz 3338692 BLAKE2B 79eb08bc446073fadf881adea0f60a2caf6384836df975f80ce0e57db6469e6a016cab38413d3de00d11b491a0281f95dcbcd1f782b31f2d1a07b866c1ed7dd5 SHA512 4a879e71f65c89609c2e106dc79222853e6f37830638d5b9624c436fc9d8974cc6474d399eff02cdc13ff7189fcd13e9450450d36c3a6092aa53cb97056f5854
+DIST gstreamer-1.18.4.tar.xz 2703948 BLAKE2B b11be1309e7a6ad0aff24aa99b10b1c16df4b1720b821421a72ec9d9b20087488901bb4667e797d32ef616f909c3aefd301fac6be9c4c4120ec9e4af3acc7b48 SHA512 5312c621fc354b35cc81f53b4ec65c661ad2c22acef2640bc27860234243d06e00e3aaf41c93d379d8424c0ecdf2ae06096dec0d0313215426348ffa0afb3c4a
diff --git a/media-libs/gstreamer/gstreamer-1.18.4.ebuild b/media-libs/gstreamer/gstreamer-1.18.4.ebuild
new file mode 100644
index 000000000000..02d997439af9
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.18.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+RDEPEND="
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}