summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 01:24:08 +0100
committerGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>2016-01-31 13:46:24 +0100
commitc611a4b9bf9f5c212c23272a19792c5d18ab43e9 (patch)
tree6f574520367337cd505b3cb6362797cfd93a88ac /media-libs/gstreamer
parentdev-tex/currvita: add missing tl-langgerman dep, bug #573442. Drop outdated b... (diff)
downloadgentoo-c611a4b9bf9f5c212c23272a19792c5d18ab43e9.tar.gz
gentoo-c611a4b9bf9f5c212c23272a19792c5d18ab43e9.tar.bz2
gentoo-c611a4b9bf9f5c212c23272a19792c5d18ab43e9.zip
media-libs/gstreamer: version bump to 1.6.3
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.6.3.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index 0797f94dccc4..0ddf6a7ab6ab 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -2,3 +2,4 @@ DIST gstreamer-0.10.36.tar.xz 3025876 SHA256 9151aa108c177054387885763fa0e433e76
DIST gstreamer-1.4.5.tar.xz 3324052 SHA256 40801aa7f979024526258a0e94707ba42b8ab6f7d2206e56adbc4433155cb0ae SHA512 ed7b371f99b7da4ec462e34cd8e02062a0faaad7498a87cfc1ef39f8740db9bca0cc5bfe17ae5ff24abe0bd4a6771e732da193c01ca0e2d835b6c5d9f0d41403 WHIRLPOOL 3065b43a84d8d1d09ec9fb9bda5afc91550cd9f55e2db486c6aceec8fa41dd5ae7d3809c6b6249e86e658c94ffed6ec5a4a7a3cd25b2ab17c24c5a3488355bee
DIST gstreamer-1.6.1.tar.xz 3552476 SHA256 973a3f213c8d41d6dd0e4e7e38fd6cccacd5ae1ac09e1179a8d5d869ef0a5c9c SHA512 30b776a7ed9e9129e98e937da3c662eab5735e13caf9bb44a290b164d462bd6ba6101650971047e8ba595cc11c99507517df3593456507b37c6c9038fbd6fd1e WHIRLPOOL cadc669d22ae3aea5a590ba057f26b5e304c9f52b9d612bce1b6081bdb98cfaba83bdd48d2893a3d37caa152f2c79d1edff6f70ae6026def8ec2d6dfde2d6d3e
DIST gstreamer-1.6.2.tar.xz 3557808 SHA256 5896716bd8e089dba452932a2eff2bb6f6c9d58ff64a96635d157f1ffaf8feb2 SHA512 c6032e8d11870668a716b546d1d1b9908e670767c41390285d4f1a89b93ec44262d901e2ba5ed251e9cbf316b41ff46d1f71d5208997f0b0b717de55df0080f9 WHIRLPOOL dd768878e175bba3318d5550556eb8b588ea3ff95db018547e3fc676d98f1b7b67b4a7d05f5c03c01ef24766daf348d27b8e6808607db5e6ccee4c334294d370
+DIST gstreamer-1.6.3.tar.xz 3553256 SHA256 22f9568d67b87cf700a111f381144bd37cb93790a77e4e331db01fe854a37f24 SHA512 f5ab2461469d489da956a0dd4e785e8f0a130b104a37289f7821be6e8f8e5049864888fdcf3a7d281406bf48b40737afa75347c22e6bec05ff2cf525734b51f7 WHIRLPOOL 386efbe1f431e247e11f7369ababb8bb5f2d457b046de1eb955cb9d2322f995c862b22124efcbeeeb9b4d25def664de952b98fe54ba71cd2438502e86ac1db7c
diff --git a/media-libs/gstreamer/gstreamer-1.6.3.ebuild b/media-libs/gstreamer/gstreamer-1.6.3.ebuild
new file mode 100644
index 000000000000..1409bf676d2e
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.6.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit bash-completion-r1 eutils multilib multilib-minimal pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection nls +orc test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( sys-devel/gettext )
+"
+# gtk-doc-am to install API docs
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]] ; then
+ export ac_cv_lib_dl_dladdr=no
+ export ac_cv_func_poll=no
+ fi
+ if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
+ # GCC groks this, but then refers to an implementation (___multi3,
+ # ___udivti3) that don't exist (at least I can't find it), so force
+ # this one to be off, such that we use 2x64bit emulation code.
+ export gst_cv_uint128_t=no
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Set 'libexecdir' to ABI-specific location for the library spawns
+ # helpers from there.
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --disable-debug
+ --disable-examples
+ --disable-static
+ --disable-valgrind
+ --enable-check
+ $(multilib_native_use_enable introspection)
+ $(use_enable nls)
+ $(use_enable test tests)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ --with-package-name="GStreamer ebuild for Gentoo"
+ --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
+ )
+
+ if use caps ; then
+ myconf+=( --with-ptp-helper-permissions=capabilities )
+ else
+ myconf+=(
+ --with-ptp-helper-permissions=setuid-root
+ --with-ptp-helper-setuid-user=nobody
+ --with-ptp-helper-setuid-group=nobody
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf ${myconf[$@]}
+
+ if multilib_is_native_abi; then
+ local x
+ for x in gst libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
+}