summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-29 17:41:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-29 17:41:01 +0200
commit0fc11078f4f3cbfaf84740917764c8a76741fcc0 (patch)
treec817697ce4cef80a8d1e4b85b17b1141a12eff21 /media-libs/harfbuzz
parentdev-util/ccache: amd64 stable (bug #738672) (diff)
downloadgentoo-0fc11078f4f3cbfaf84740917764c8a76741fcc0.tar.gz
gentoo-0fc11078f4f3cbfaf84740917764c8a76741fcc0.tar.bz2
gentoo-0fc11078f4f3cbfaf84740917764c8a76741fcc0.zip
media-libs/harfbuzz: bump to v2.7.2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.7.2.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 354d2bf84938..85f3068e686c 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -3,3 +3,4 @@ DIST harfbuzz-2.6.7.tar.xz 9001936 BLAKE2B bd3a195506253a1446e877c35c067cc874826
DIST harfbuzz-2.6.8.tar.xz 8976516 BLAKE2B 46401ae06ec70172621d2aa354901f03173a273abdb0db909332946643e82b4286be690ac717a29304e9db121dd7f693b4ce19522de772f5d140986d6333e7ce SHA512 651b23d7d4fab6fef472ee57db39bbaebc31c2f40ea3a482c1499ad1a7b549b86a2bccbe9da191c8e9ecdf464191dd3c9a7485546b51695ad8ab3c0329732d9d
DIST harfbuzz-2.7.0.tar.gz 16278518 BLAKE2B 4d4bcbcd08c90cbdb34f8aca3571bcd836d578e7eab81187d7dba8a19ae586744b5f9ac83cfb6a50302648c502a87f4aa9dccdfbf39edc70d4318d831f4a55b0 SHA512 65d5b9bd3a53be659dd7d220da220f6873f7246c2ab11205132998e4ac4245fcf51b6968e705b81cc7652db5bbacc90c8db977cf1020edf7957a626a19e055c0
DIST harfbuzz-2.7.1.tar.gz 16603949 BLAKE2B 4c1792dfb8f2c777efb2f01dfc7e4642bda507813d21db5beee467b1368e991db0f0c3f903662da0a267e7af9a6c30bb258fa057e42d3096f9f8d23ccf4bac9e SHA512 a04864e0f5e523e9d025f066e0850afdfdf53acc9881c0284034ab4384088b118551a899ae5e77bbd821c344b97fb5e0a3d4506bbb812eb0019080be7b3f75f1
+DIST harfbuzz-2.7.2.tar.gz 16605557 BLAKE2B 246ab64e29afcadc692b57bad84acdea1f9200a63f6f8b1519d12b8515ec65dc45e2edf3abdde473b71364427a689d92ce2ee25c514edf4b1e680dd423d774ee SHA512 2eeb198dab1ed1cc7d10c3890293ff40e9f37372413877a5bd44d66e88d8460a81f51cbe71c328b1300f542ca8de3269749d1d01d0c324c8b95a9c038fbe1521
diff --git a/media-libs/harfbuzz/harfbuzz-2.7.2.ebuild b/media-libs/harfbuzz/harfbuzz-2.7.2.ebuild
new file mode 100644
index 000000000000..d8d692333627
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-2.7.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit flag-o-matic meson multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug doc +glib +graphite icu +introspection static-libs test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ sed -i \
+ -e 's:tests/macos.tests::' \
+ test/shaping/data/in-house/Makefile.sources \
+ || die # bug 726120
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+meson_multilib_native_feature() {
+ if multilib_is_native_abi && use "$1" ; then
+ echo "enabled"
+ else
+ echo "disabled"
+ fi
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local emesonargs=(
+ -Dcairo="$(meson_multilib_native_feature cairo)"
+ -Dcoretext="disabled"
+ -Ddocs="$(meson_multilib_native_feature doc)"
+ -Dfontconfig="disabled" #609300
+ -Dintrospection="$(meson_multilib_native_feature introspection)"
+ -Dstatic="$(usex static-libs true false)"
+ $(meson_feature glib)
+ $(meson_feature graphite)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}