summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2021-01-02 23:26:42 +0100
committerSam James <sam@gentoo.org>2021-01-24 01:48:04 +0000
commit3879f7d07fd0e99b3dc26e63f1134ac202a6dd1a (patch)
tree934bfd85ccb0bf459fea0b2b3e8b97e8db08d09b /media-libs/ilmbase
parentx11-terms/kitty-terminfo: bump to 0.19.3 (diff)
downloadgentoo-3879f7d07fd0e99b3dc26e63f1134ac202a6dd1a.tar.gz
gentoo-3879f7d07fd0e99b3dc26e63f1134ac202a6dd1a.tar.bz2
gentoo-3879f7d07fd0e99b3dc26e63f1134ac202a6dd1a.zip
media-libs/ilmbase: bump to 2.5.4
Bug: https://bugs.gentoo.org/746794 Bug: https://bugs.gentoo.org/762862 Bug: https://bugs.gentoo.org/762901 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/ilmbase')
-rw-r--r--media-libs/ilmbase/Manifest1
-rw-r--r--media-libs/ilmbase/files/ilmbase-2.5.4-0001-disable-failing-test-on-x86_32.patch24
-rw-r--r--media-libs/ilmbase/ilmbase-2.5.4.ebuild42
3 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/ilmbase/Manifest b/media-libs/ilmbase/Manifest
index 2418671100a6..c6dd7455c337 100644
--- a/media-libs/ilmbase/Manifest
+++ b/media-libs/ilmbase/Manifest
@@ -1,3 +1,4 @@
DIST ilmbase-2.3.0.tar.gz 595490 BLAKE2B db956fe7dbabf94632eb98635f4ebda8e937f26e26ed69f33743069fa2bf6d5ed3711f00eb33377c98b4f8ea367bbfc51b11d4cb884ce02238b537857cc19a9c SHA512 db0804a7c37c2a97f9dbf81b20f40f7fdea73242baa2759d9dc3728e6849e7ecae0e178fa1c710add980d050499151650675e4b2cda6cbbaa61aca406a1f929a
DIST ilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
DIST ilmbase-2.5.3.tar.gz 27534825 BLAKE2B 4647b4aac074b10c0d1fb35ddb6b5acefca81c0f2debde04987b5df4e290b14b6406fc922949449aaeea7cf4be371a25c93f8fcb9f67c63d65276340bd586a21 SHA512 6da03193d4fea1e97e35008f59304ab408c521ead8495ba411cde5c172cf953be97999971f57398b813d14f1af1d722539a6b74d5ee54b9e74769ea8258d36ba
+DIST ilmbase-2.5.4.tar.gz 27535491 BLAKE2B 8951383d31ceea49202e3b77999d71c261bc9a17433fb65debd446aefd62cc1f6776a4b37fb1161196135a8883a397a94496a2295a2e0d22bc43c59e2ad0eaa5 SHA512 f0fe305987981e0c7e5a854367702585e4935ad37b0e8c10dcbc7468ae3a6d34bf963ec9ec75cc3abe4cf00e359644476b643978d0289dca46c9785a25d3f7f1
diff --git a/media-libs/ilmbase/files/ilmbase-2.5.4-0001-disable-failing-test-on-x86_32.patch b/media-libs/ilmbase/files/ilmbase-2.5.4-0001-disable-failing-test-on-x86_32.patch
new file mode 100644
index 000000000000..e22ae13c4bb3
--- /dev/null
+++ b/media-libs/ilmbase/files/ilmbase-2.5.4-0001-disable-failing-test-on-x86_32.patch
@@ -0,0 +1,24 @@
+From a5e853655daf9e6a8ca8d8b7b5040809d4d9fded Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 2 Jan 2021 22:07:05 +0100
+Subject: [PATCH] disable failing test on x86_32
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 759f359..6fab418 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,5 +56,5 @@ if(BUILD_TESTING)
+
+ add_subdirectory( HalfTest )
+ add_subdirectory( IexTest )
+- add_subdirectory( ImathTest )
++# add_subdirectory( ImathTest )
+ endif()
+--
+2.30.0
+
diff --git a/media-libs/ilmbase/ilmbase-2.5.4.ebuild b/media-libs/ilmbase/ilmbase-2.5.4.ebuild
new file mode 100644
index 000000000000..f7961017b7aa
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="large-stack static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/openexr-${PV}/IlmBase"
+
+DOCS=( README.md )
+
+src_prepare() {
+ if use abi_x86_32; then
+ eapply "${FILESDIR}"/${P}-0001-disable-failing-test-on-x86_32.patch
+ fi
+
+ multilib_foreach_abi cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DILMBASE_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DILMBASE_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DILMBASE_INSTALL_PKG_CONFIG=ON
+ )
+
+ cmake_src_configure
+}