summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/imlib2/imlib2-1.4.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/imlib2/imlib2-1.4.7.ebuild')
-rw-r--r--media-libs/imlib2/imlib2-1.4.7.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/imlib2/imlib2-1.4.7.ebuild b/media-libs/imlib2/imlib2-1.4.7.ebuild
new file mode 100644
index 000000000000..c307d51d0687
--- /dev/null
+++ b/media-libs/imlib2/imlib2-1.4.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+EGIT_SUB_PROJECT="legacy"
+EGIT_URI_APPEND=${PN}
+
+if [[ ${PV} != "9999" ]] ; then
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment toolchain-funcs multilib-minimal
+
+DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
+HOMEPAGE="http://www.enlightenment.org/"
+
+IUSE="bzip2 gif jpeg cpu_flags_x86_mmx mp3 png static-libs tiff X zlib"
+
+RDEPEND="=media-libs/freetype-2*[${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ gif? ( >=media-libs/giflib-4.1.6-r3[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-4.0.3-r6:0[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ )
+ mp3? ( >=media-libs/libid3tag-0.15.1b-r3[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ png? ( >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ )"
+
+multilib_src_configure() {
+ # imlib2 has diff configure options for x86/amd64 mmx
+ if [[ $(tc-arch) == amd64 ]]; then
+ E_ECONF+=( $(use_enable cpu_flags_x86_mmx amd64) --disable-mmx )
+ else
+ E_ECONF+=( --disable-amd64 $(use_enable cpu_flags_x86_mmx mmx) )
+ fi
+
+ [[ $(gcc-major-version) -ge 4 ]] && E_ECONF+=( --enable-visibility-hiding )
+
+ ECONF_SOURCE="${S}" \
+ E_ECONF+=(
+ $(use_enable static-libs static)
+ $(use_with X x)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with gif)
+ $(use_with zlib)
+ $(use_with bzip2)
+ $(use_with mp3 id3)
+ )
+
+ enlightenment_src_configure
+}
+
+multilib_src_install() {
+ enlightenment_src_install
+}