summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/iulib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/iulib')
-rw-r--r--media-libs/iulib/Manifest2
-rw-r--r--media-libs/iulib/files/iulib-0.3-install.patch40
-rw-r--r--media-libs/iulib/files/iulib-0.4-scons-build-env.patch39
-rw-r--r--media-libs/iulib/iulib-0.3.ebuild38
-rw-r--r--media-libs/iulib/iulib-0.4.ebuild53
-rw-r--r--media-libs/iulib/metadata.xml8
6 files changed, 180 insertions, 0 deletions
diff --git a/media-libs/iulib/Manifest b/media-libs/iulib/Manifest
new file mode 100644
index 000000000000..b80e21fdf8a2
--- /dev/null
+++ b/media-libs/iulib/Manifest
@@ -0,0 +1,2 @@
+DIST iulib-0.3.tar.gz 3065868 SHA256 229f6c6b3724a442efd7306def6d2b35cd7ad38ec725adc6446632c9e8cd20f2
+DIST iulib-0.4.tgz 3288112 SHA256 c70dab420f5ce0ff0185c922881576f4a82eacec3feb0befa66bd7468151d99b
diff --git a/media-libs/iulib/files/iulib-0.3-install.patch b/media-libs/iulib/files/iulib-0.3-install.patch
new file mode 100644
index 000000000000..542420c4a13a
--- /dev/null
+++ b/media-libs/iulib/files/iulib-0.3-install.patch
@@ -0,0 +1,40 @@
+http://code.google.com/p/iulib/issues/detail?id=3
+
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@ POST_UNINSTALL = :
+ @have_vidio_TRUE@am__append_4 = $(srcdir)/vidio/vidio.h
+ @have_v4l2_TRUE@am__append_5 = $(srcdir)/vidio/v4l2cap.cc
+ subdir = .
+-DIST_COMMON = $(am__configure_deps) $(am__include_HEADERS_DIST) \
++DIST_COMMON = README $(am__configure_deps) $(am__include_HEADERS_DIST) \
+ $(colib_HEADERS) $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+ $(top_srcdir)/configure COPYING INSTALL TODO depcomp \
+ install-sh missing
+@@ -997,6 +997,7 @@ installdirs:
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(colibdir)" "$(DESTDIR)$(includedir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
++install: install-am
+ install-exec: install-exec-am
+ install-data: install-data-am
+ uninstall: uninstall-am
+@@ -1088,18 +1089,6 @@ uninstall-am: uninstall-colibHEADERS uninstall-includeHEADERS \
+ uninstall-am uninstall-colibHEADERS uninstall-includeHEADERS \
+ uninstall-info-am uninstall-libLIBRARIES
+
+-
+-# make installation of colib a separate target
+-
+-install-colib:
+- install -d $(colibdir)
+- install $(colib_HEADERS) $(colibdir)
+-
+-install: all install-colib
+- install -d $(includedir)
+- install -d $(libdir)
+- install $(include_HEADERS) $(includedir)
+- install $(lib_LIBRARIES) $(libdir)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/media-libs/iulib/files/iulib-0.4-scons-build-env.patch b/media-libs/iulib/files/iulib-0.4-scons-build-env.patch
new file mode 100644
index 000000000000..3983d9c820b4
--- /dev/null
+++ b/media-libs/iulib/files/iulib-0.4-scons-build-env.patch
@@ -0,0 +1,39 @@
+--- SConstruct
++++ SConstruct
+@@ -36,12 +36,25 @@
+
+ ### Options exposed via SCons
+ opts = Options('custom.py')
+-opts.Add('opt', 'Compiler flags for optimization/debugging', "-g -O3")
++opts.Add('opt', 'Compiler flags for optimization/debugging', "")
+ opts.Add('warn', 'Compiler flags for warnings', "-Wall -D__warn_unused_result__=__far__")
+ opts.Add('prefix', 'The installation root for iulib', "/usr/local")
+
++env = Environment(options=opts)
++
++import SCons.Util
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++
+ ### globals
+-env = Environment(options=opts, CXXFLAGS="${opt} ${warn}")
+ Help(opts.GenerateHelpText(env))
+ conf = Configure(env)
+ if "-DUNSAFE" in env["opt"]:
+@@ -134,7 +147,7 @@
+ src_suffix = '')
+ progs.Append(BUILDERS={'Test':test_builder})
+
+-if True: #"test" in COMMAND_LINE_TARGETS:
++if "test" in COMMAND_LINE_TARGETS:
+ for file in glob.glob("*/test-*.cc") + glob.glob("*/*/test-*.cc"):
+ if not file.startswith('vidio'):
+ progs.Program(file[:-3],file)
diff --git a/media-libs/iulib/iulib-0.3.ebuild b/media-libs/iulib/iulib-0.3.ebuild
new file mode 100644
index 000000000000..96413a6512c6
--- /dev/null
+++ b/media-libs/iulib/iulib-0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="easy-to-use image and video I/O functions"
+HOMEPAGE="http://code.google.com/p/iulib/"
+SRC_URI="http://iulib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="sdl"
+
+DEPEND="sys-libs/zlib
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/tiff
+ sdl? ( media-libs/libsdl )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_compile() {
+ econf $(use_with sdl SDL) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc CHANGES README TODO
+}
diff --git a/media-libs/iulib/iulib-0.4.ebuild b/media-libs/iulib/iulib-0.4.ebuild
new file mode 100644
index 000000000000..edb8dacc1607
--- /dev/null
+++ b/media-libs/iulib/iulib-0.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib scons-utils
+
+DESCRIPTION="easy-to-use image and video I/O functions"
+HOMEPAGE="http://code.google.com/p/iulib/"
+SRC_URI="http://iulib.googlecode.com/files/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sdl"
+
+RDEPEND="sys-libs/zlib
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/tiff
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ )"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4-scons-build-env.patch
+ sed -i \
+ -e "/^have_sdl = 1/s:1:$(usex sdl 1 0):" \
+ -e '/tiff/s:inflate:TIFFOpen:' \
+ -e '/progs.Append(LIBS=libiulib)/s:Append:Prepend:' \
+ -e "/^libdir/s:/lib:/$(get_libdir):" \
+ SConstruct || die #297326 #308955 #310439
+ sed -i '/SDL.SDL_image.h/d' utils/dgraphics.cc || die #310443
+ tc-export AR CC CXX RANLIB
+}
+
+src_configure() {
+ # Avoid configure as we build/install with scons
+ :
+}
+
+src_compile() {
+ escons prefix=/usr
+}
+
+src_install() {
+ escons prefix="${D}"/usr install
+ dodoc CHANGES README TODO
+}
diff --git a/media-libs/iulib/metadata.xml b/media-libs/iulib/metadata.xml
new file mode 100644
index 000000000000..0213a52c37fe
--- /dev/null
+++ b/media-libs/iulib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <upstream>
+ <remote-id type="google-code">iulib</remote-id>
+ </upstream>
+</pkgmetadata>