summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-14 18:20:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-14 18:20:18 +0200
commit62d6aa651cc9cba85937b117a0d8a00e24cf0f22 (patch)
treed8bd2b471cff7e26b36613dd713d244fdcd76206 /media-libs/kvazaar/kvazaar-9999.ebuild
parentnet-misc/wireguard: bump (diff)
downloadgentoo-62d6aa651cc9cba85937b117a0d8a00e24cf0f22.tar.gz
gentoo-62d6aa651cc9cba85937b117a0d8a00e24cf0f22.tar.bz2
gentoo-62d6aa651cc9cba85937b117a0d8a00e24cf0f22.zip
media-libs/kvazaar: Bump to 1.0.0.
Fix tests by downloading greatest, bug #595932 Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/kvazaar/kvazaar-9999.ebuild')
-rw-r--r--media-libs/kvazaar/kvazaar-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/media-libs/kvazaar/kvazaar-9999.ebuild b/media-libs/kvazaar/kvazaar-9999.ebuild
index 4d22819d2749..7f8fec2b518d 100644
--- a/media-libs/kvazaar/kvazaar-9999.ebuild
+++ b/media-libs/kvazaar/kvazaar-9999.ebuild
@@ -6,25 +6,28 @@ EAPI=5
SCM=""
+GREATEST_PV="1.2.1"
+
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi
-inherit multilib autotools multilib-minimal toolchain-funcs ${SCM}
+inherit eutils multilib autotools multilib-minimal toolchain-funcs ${SCM}
DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
if [ "${PV#9999}" = "${PV}" ] ; then
- SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
KEYWORDS="~amd64 ~ppc"
fi
LICENSE="LGPL-2.1"
# subslot = libkvazaar major
SLOT="0/3"
-IUSE="cpu_flags_x86_avx2 static-libs"
+IUSE="static-libs test"
DEPEND=""
RDEPEND="${DEPEND}"
@@ -36,14 +39,18 @@ DEPEND="${DEPEND}
src_prepare() {
eautoreconf
+ if use test ; then
+ # https://bugs.gentoo.org/show_bug.cgi?id=595932
+ rmdir "${S}/greatest" || die
+ mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
+ fi
}
multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
--docdir "/usr/share/doc/${PF}" \
- $(use_enable static-libs static) \
- $(use_enable cpu_flags_x86_avx2 asm)
+ $(use_enable static-libs static)
}
multilib_src_install_all() {