summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-27 19:02:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-27 19:18:04 +0200
commitf0f3677537f204ec4473b3b4b37d30276b890271 (patch)
treec0c564bb175e000c90f60c01dadb258f3d1a5c5a /media-libs/kvazaar
parentmedia-libs/liblscp: Drop 0.5.8-r1 (diff)
downloadgentoo-f0f3677537f204ec4473b3b4b37d30276b890271.tar.gz
gentoo-f0f3677537f204ec4473b3b4b37d30276b890271.tar.bz2
gentoo-f0f3677537f204ec4473b3b4b37d30276b890271.zip
media-libs/kvazaar: Drop old
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/kvazaar')
-rw-r--r--media-libs/kvazaar/Manifest1
-rw-r--r--media-libs/kvazaar/files/gcc7.patch46
-rw-r--r--media-libs/kvazaar/kvazaar-1.1.0.ebuild60
-rw-r--r--media-libs/kvazaar/kvazaar-1.2.0.ebuild55
4 files changed, 0 insertions, 162 deletions
diff --git a/media-libs/kvazaar/Manifest b/media-libs/kvazaar/Manifest
index a1c41dca3700..2fa789b2afd9 100644
--- a/media-libs/kvazaar/Manifest
+++ b/media-libs/kvazaar/Manifest
@@ -1,3 +1,2 @@
DIST greatest-1.2.1.tar.gz 19792 BLAKE2B e6abd20eebf3223311fcd62e341595318dd00f192cf4b62ef3f0443a3e10fee71f4283f836931fee52672f2b37398f86046ae97220c2b6c6045fec9f9bf5cda8 SHA512 c17162fa222c84fef7826ba5202aae573d516a71bc2c59c8991db2a76f7069ed53d00aaab1b792e0c7e4243fae38183764c2e7ae0a61faf2ff13e78b29ccc211
-DIST kvazaar-1.1.0.tar.gz 484601 BLAKE2B fc35fe5bbd12779d4e14b8cef6fbc6950f188ccffef567c77411bf32f80f2e355f235ad9df4762f8a615415778b322715d09d21a910a256d1bb2054bc13dbdb2 SHA512 72cee44e32c76c0a94acf33347457145d3f88d644fb4703588d0db6bff1c7064c9b623034efe4ba39219150767012544e4f45141b6a6183d41e4a29c6cb258b9
DIST kvazaar-1.2.0.tar.gz 486455 BLAKE2B e7b9ceee4e4edeb051128cfa798e59114cd9175b5ba8a4531c7e872327658c58d22ad21ce40b1b71c632e94cef96b78b77646048629683d24bf69107497f1acd SHA512 5a28c1b21e47d9f45e04ee40a253f478c4ce3c6c41134db8301e843ef0b5d620bce493eacf82ce1ddda88140aa4d2e9401612b63ff592fc2273cf532458d2bb4
diff --git a/media-libs/kvazaar/files/gcc7.patch b/media-libs/kvazaar/files/gcc7.patch
deleted file mode 100644
index 12ff8ad00ff7..000000000000
--- a/media-libs/kvazaar/files/gcc7.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-commit 47a9f0de049e77e866ea5bdd4bc7c795ea6dd641
-Author: Ari Lemmetti <ari.lemmetti@gmail.com>
-Date: Tue Apr 11 12:57:22 2017 +0300
-
- Modify and use FILL_ARRAY macro to prevent warning on GCC 7
-
- Following warning was given and is false positive
-
- error: 'memset' used with length equal to number of elements without multiplication by element size [-Werror=memset-elt-size]
-
-diff --git a/src/global.h b/src/global.h
-index bedcd49..5181674 100644
---- a/src/global.h
-+++ b/src/global.h
-@@ -219,7 +219,11 @@ typedef int16_t coeff_t;
- // Fill a structure or a static array with val bytes.
- #define FILL(var, val) memset(&(var), (val), sizeof(var))
- // Fill a number of elements in an array with val bytes.
--#define FILL_ARRAY(ar, val, size) memset((ar), (val), (size) * sizeof(*(ar)))
-+#define FILL_ARRAY(ar, val, size) \
-+{\
-+ void *temp_ptr = (void*)(ar);\
-+ memset((temp_ptr), (val), (size) * sizeof(*(ar)));\
-+}
-
- #define FREE_POINTER(pointer) { free((void*)pointer); pointer = NULL; }
- #define MOVE_POINTER(dst_pointer,src_pointer) { dst_pointer = src_pointer; src_pointer = NULL; }
-diff --git a/src/rdo.c b/src/rdo.c
-index 52305fd..2579f28 100644
---- a/src/rdo.c
-+++ b/src/rdo.c
-@@ -558,10 +558,10 @@ void kvz_rdoq(encoder_state_t * const state, coeff_t *coef, coeff_t *dest_coeff,
- // Explicitly tell the only possible numbers of elements to be zeroed.
- // Hope the compiler is able to utilize this information.
- switch (cg_num) {
-- case 1: memset(sig_coeffgroup_flag, 0, 1 * sizeof(sig_coeffgroup_flag[0])); break;
-- case 4: memset(sig_coeffgroup_flag, 0, 4 * sizeof(sig_coeffgroup_flag[0])); break;
-- case 16: memset(sig_coeffgroup_flag, 0, 16 * sizeof(sig_coeffgroup_flag[0])); break;
-- case 64: memset(sig_coeffgroup_flag, 0, 64 * sizeof(sig_coeffgroup_flag[0])); break;
-+ case 1: FILL_ARRAY(sig_coeffgroup_flag, 0, 1); break;
-+ case 4: FILL_ARRAY(sig_coeffgroup_flag, 0, 4); break;
-+ case 16: FILL_ARRAY(sig_coeffgroup_flag, 0, 16); break;
-+ case 64: FILL_ARRAY(sig_coeffgroup_flag, 0, 64); break;
- default: assert(0 && "There should be 1, 4, 16 or 64 coefficient groups");
- }
-
diff --git a/media-libs/kvazaar/kvazaar-1.1.0.ebuild b/media-libs/kvazaar/kvazaar-1.1.0.ebuild
deleted file mode 100644
index 88a19051ba67..000000000000
--- a/media-libs/kvazaar/kvazaar-1.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-SCM=""
-
-GREATEST_PV="1.2.1"
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
-fi
-
-inherit eutils multilib autotools multilib-minimal toolchain-funcs ${SCM}
-
-DESCRIPTION="An open-source HEVC encoder"
-HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
-
-if [ "${PV#9999}" = "${PV}" ] ; then
- SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
-fi
-
-LICENSE="LGPL-2.1"
-# subslot = libkvazaar major
-SLOT="0/3"
-IUSE="static-libs test"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( static-libs )"
-
-ASM_DEP=">=dev-lang/yasm-1.2.0"
-DEPEND="${DEPEND}
- abi_x86_32? ( ${ASM_DEP} )
- abi_x86_64? ( ${ASM_DEP} )"
-
-src_prepare() {
- epatch "${FILESDIR}/gcc7.patch"
- eautoreconf
- if use test && [ "${PV#9999}" = "${PV}" ]; then
- # https://bugs.gentoo.org/show_bug.cgi?id=595932
- rmdir "${S}/greatest" || die
- mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
- fi
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- --disable-werror \
- --docdir "/usr/share/doc/${PF}" \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- find "${ED}" -name '*.la' -delete
-}
diff --git a/media-libs/kvazaar/kvazaar-1.2.0.ebuild b/media-libs/kvazaar/kvazaar-1.2.0.ebuild
deleted file mode 100644
index 48ce175d0487..000000000000
--- a/media-libs/kvazaar/kvazaar-1.2.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GREATEST_PV="1.2.1"
-
-if [[ ${PV} = *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
-else
- SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-inherit autotools flag-o-matic multilib-minimal toolchain-funcs
-
-DESCRIPTION="Open-source HEVC encoder"
-HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
-
-LICENSE="LGPL-2.1"
-# subslot = libkvazaar major
-SLOT="0/4"
-IUSE="static-libs test"
-REQUIRED_USE="test? ( static-libs )"
-
-ASM_DEP=">=dev-lang/yasm-1.2.0"
-RDEPEND=""
-DEPEND="${RDEPEND}
- abi_x86_32? ( ${ASM_DEP} )
- abi_x86_64? ( ${ASM_DEP} )
-"
-
-src_prepare() {
- default
- sed -e "/^dist_doc_DATA/s/COPYING //" -i Makefile.am || die
- eautoreconf
- if use test && [[ ${PV} != *9999 ]]; then
- # https://bugs.gentoo.org/show_bug.cgi?id=595932
- rmdir "${S}/greatest" || die
- mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
- fi
- # Some m4 macros append Werror, we do not want that.
- append-flags "-Wno-error"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-werror \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- find "${ED}" -name '*.la' -delete || die
-}