summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-09-20 12:40:29 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-09-20 12:40:48 +0300
commit70f7e67a191e3ac05a2c7df1c4ecdaf766e4f38d (patch)
treec0a480c0c2cfd1c532ec59867b33bfc859269993 /media-libs/lensfun
parentpackage.mask: Last rite dev-python/pyogg, dev-python/python-fchksum (diff)
downloadgentoo-70f7e67a191e3ac05a2c7df1c4ecdaf766e4f38d.tar.gz
gentoo-70f7e67a191e3ac05a2c7df1c4ecdaf766e4f38d.tar.bz2
gentoo-70f7e67a191e3ac05a2c7df1c4ecdaf766e4f38d.zip
media-libs/lensfun: Fix warnings that clang turns into errors
Closes: https://bugs.gentoo.org/740072 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/files/lensfun-0.3.2-warnings.patch48
-rw-r--r--media-libs/lensfun/lensfun-0.3.2-r1.ebuild4
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/lensfun/files/lensfun-0.3.2-warnings.patch b/media-libs/lensfun/files/lensfun-0.3.2-warnings.patch
new file mode 100644
index 000000000000..a1aad34d9d28
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.3.2-warnings.patch
@@ -0,0 +1,48 @@
+Adapted from upstream commit
+
+From 694542f350fc7c9ccafa2d9acb4d4e00e690cbdc Mon Sep 17 00:00:00 2001
+From: Sebastian Kraft <mail@sebastiankraft.net>
+Date: Thu, 22 Dec 2016 18:51:29 +0100
+Subject: [PATCH] Fix some warnings which were introduced when swithcing to
+ C++11 mode
+
+---
+ libs/lensfun/cpuid.cpp | 4 ++--
+ libs/lensfun/mod-pc.cpp | 8 ++++----
+ tests/test_modifier.cpp | 4 ++--
+ 3 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/libs/lensfun/cpuid.cpp b/libs/lensfun/cpuid.cpp
+index c435f8ac..d2d63972 100644
+--- a/libs/lensfun/cpuid.cpp
++++ b/libs/lensfun/cpuid.cpp
+@@ -92,9 +92,9 @@ guint _lf_detect_cpu_features ()
+ {
+ #define cpuid(cmd) \
+ __asm volatile ( \
+- "push %%"R_BX"\n" \
++ "push %%" R_BX "\n" \
+ "cpuid\n" \
+- "pop %%"R_BX"\n" \
++ "pop %%" R_BX "\n" \
+ : "=a" (ax), "=c" (cx), "=d" (dx) \
+ : "0" (cmd))
+
+diff --git a/tests/test_modifier.cpp b/tests/test_modifier.cpp
+index f087917c..ffa3d4d7 100644
+--- a/tests/test_modifier.cpp
++++ b/tests/test_modifier.cpp
+@@ -78,8 +78,8 @@ void test_mod_projection_center(lfFixture* lfFix, gconstpointer data)
+ // check if output becomes NaN when processing geometry conversion
+ void test_mod_projection_borders(lfFixture* lfFix, gconstpointer data)
+ {
+- float in[2] = {lfFix->img_width, lfFix->img_height};
+- float in2[2] = {(lfFix->img_width-1)/2, (lfFix->img_height-1)/2};
++ float in[2] = {(float) lfFix->img_width, (float) lfFix->img_height};
++ float in2[2] = {(float) (lfFix->img_width-1)/2, (float) (lfFix->img_height-1)/2};
+ float res[2] = {0, 0};
+
+ lfLensType geom_types [] = {LF_RECTILINEAR, LF_PANORAMIC, LF_EQUIRECTANGULAR, LF_FISHEYE_STEREOGRAPHIC, LF_FISHEYE, LF_FISHEYE_EQUISOLID, LF_FISHEYE_ORTHOGRAPHIC, LF_FISHEYE_THOBY, LF_UNKNOWN};
+--
+2.26.2
+
diff --git a/media-libs/lensfun/lensfun-0.3.2-r1.ebuild b/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
index 528d11db7368..ef48ba8d722a 100644
--- a/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
+++ b/media-libs/lensfun/lensfun-0.3.2-r1.ebuild
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}"
DOCS=( README.md docs/mounts.txt ChangeLog )
+PATCHES=(
+ "${FILESDIR}/${P}-warnings.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html