summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libafterimage/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libafterimage/files')
-rw-r--r--media-libs/libafterimage/files/libafterimage-config.patch15
-rw-r--r--media-libs/libafterimage/files/libafterimage-gif.patch18
-rw-r--r--media-libs/libafterimage/files/libafterimage-giflib42.patch19
-rw-r--r--media-libs/libafterimage/files/libafterimage-libpng15.patch31
-rw-r--r--media-libs/libafterimage/files/libafterimage-makefile.in.patch62
5 files changed, 145 insertions, 0 deletions
diff --git a/media-libs/libafterimage/files/libafterimage-config.patch b/media-libs/libafterimage/files/libafterimage-config.patch
new file mode 100644
index 000000000000..d2ed9e032953
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-config.patch
@@ -0,0 +1,15 @@
+--- afterimage-config.in 2005-01-12 18:03:36.000000000 +0000
++++ afterimage-config.in.new 2006-10-15 14:16:12.000000000 +0100
+@@ -110,11 +110,7 @@
+ libs="-lAfterBase $libs"
+ fi
+ libs="-lAfterImage $libs"
+- if test "@libdir@" != "/usr/lib" ; then
+- echo -L@libdir@ $libs
+- else
+- echo $libs
+- fi
++ echo $libs
+ else
+ echo $libs
+ fi
diff --git a/media-libs/libafterimage/files/libafterimage-gif.patch b/media-libs/libafterimage/files/libafterimage-gif.patch
new file mode 100644
index 000000000000..8a2ca8e46720
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-gif.patch
@@ -0,0 +1,18 @@
+--- configure.in.orig 2011-03-28 18:55:22.000000000 +0100
++++ configure.in 2011-03-28 18:56:08.000000000 +0100
+@@ -60,12 +60,9 @@
+ dnl# AC_ARG_WITH(xpm_includes, [ --with-xpm-includes=DIR use libXpm includes in DIR( when builtin XPM handling is disabled )], xpm_includes="$withval", xpm_includes=no)
+
+ dnl# standard libgif/ungif should not be used and considered obsolete!
+-dnl# AC_ARG_WITH(ungif, [ --with-ungif support Uncompressed GIF image format using libungif [no]],with_ungif="$withval",with_ungif=no)
+-dnl# AC_ARG_WITH(gif, [ --with-gif support GIF image format using libgif [no]],with_gif="$withval",with_gif=no)
+-dnl# AC_ARG_WITH(gif_includes, [ --with-gif-includes=DIR use GIF includes in DIR], gif_includes="$withval", gif_includes=no)
+-with_ungif=no
+-with_gif=no
+-with_gif_includes=no
++AC_ARG_WITH(ungif, [ --with-ungif support Uncompressed GIF image format using libungif [no]],with_ungif="$withval",with_ungif=no)
++AC_ARG_WITH(gif, [ --with-gif support GIF image format using libgif [no]],with_gif="$withval",with_gif=no)
++AC_ARG_WITH(gif_includes, [ --with-gif-includes=DIR use GIF includes in DIR], gif_includes="$withval", gif_includes=no)
+ AC_ARG_WITH(builtin_gif, [ --with-builtin-gif support Uncompressed GIF image format using builtin libgif [yes]],with_builtin_gif="$withval",with_builtin_gif=yes)
+
+
diff --git a/media-libs/libafterimage/files/libafterimage-giflib42.patch b/media-libs/libafterimage/files/libafterimage-giflib42.patch
new file mode 100644
index 000000000000..b1b1f7263da1
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-giflib42.patch
@@ -0,0 +1,19 @@
+Fix build failure with giflib 4.2.
+Patch by Andrew Savchenko <bircoph@gmail.com>.
+https://bugs.gentoo.org/486804
+
+--- libAfterImage-1.20/ungif.h.orig
++++ libAfterImage-1.20/ungif.h
+@@ -7,6 +7,12 @@
+ extern "C" {
+ #endif
+
++#if (GIFLIB_MAJOR>4) || ((GIFLIB_MAJOR==4) && (GIFLIB_MINOR>=2))
++static inline void PrintGifError(void) {
++ fprintf(stderr, "%s\n", GifErrorString());
++}
++#endif
++
+ #ifdef __GNUC__
+ #define ASIM_PrintGifError() do{ fprintf( stderr, "%s():%d:<%s> ",__FUNCTION__, __LINE__, path?path:"null" ); PrintGifError(); }while(0)
+ #else
diff --git a/media-libs/libafterimage/files/libafterimage-libpng15.patch b/media-libs/libafterimage/files/libafterimage-libpng15.patch
new file mode 100644
index 000000000000..44d5b944007c
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-libpng15.patch
@@ -0,0 +1,31 @@
+--- export.c
++++ export.c
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- import.c
++++ import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }
diff --git a/media-libs/libafterimage/files/libafterimage-makefile.in.patch b/media-libs/libafterimage/files/libafterimage-makefile.in.patch
new file mode 100644
index 000000000000..a41f90a64c58
--- /dev/null
+++ b/media-libs/libafterimage/files/libafterimage-makefile.in.patch
@@ -0,0 +1,62 @@
+--- Makefile.in.orig 2005-08-16 10:00:02.000000000 +0200
++++ Makefile.in 2005-08-16 10:00:35.000000000 +0200
+@@ -79,7 +79,7 @@
+ MV = @MV@
+ RM = @RM@
+ RMF = @RM@ -f
+-MKDIR = @MKDIR@
++MKDIR = @MKDIR@ -p
+ FIND = @FIND@
+ XARGS = @XARGS@
+ LDCONFIG = @LDCONFIG@
+@@ -135,20 +135,6 @@
+ @(if [ -d $(LIBDIR) ] && [ -w $(LIBDIR) ]; then \
+ echo "$(INSTALL_LIB) $(LIB_STATIC) $(LIBDIR)"; \
+ $(INSTALL_LIB) $(LIB_STATIC) $(LIBDIR); \
+- if [ `uname` = "Linux" ]; then \
+- if test $(LIBDIR) = "/lib" || test $(LIBDIR) = "/usr/lib"; then \
+- echo "" > /dev/null; \
+- elif grep -q $(LIBDIR) /etc/ld.so.conf > /dev/null 2>&1; then \
+- echo "" > /dev/null; \
+- else \
+- echo "Unable to find $(LIBDIR) in ld.so.conf. In order to use "; \
+- echo "$(LIB_STATIC), you may need to add it or set LD_LIBRARY_PATH."; \
+- fi; \
+- if test -w /etc; then \
+- echo "$(LDCONFIG)"; \
+- $(LDCONFIG); \
+- fi; \
+- fi ;\
+ fi \
+ )
+
+@@ -161,18 +147,6 @@
+ $(RM) -f $(LIBDIR)/$(LIB_SHARED).$(LIBVERMAJOR) $(LIBDIR)/$(LIB_SHARED); \
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIBDIR)/$(LIB_SHARED).$(LIBVERMAJOR); \
+ $(LN_S) -f $(LIB_SHARED).$(LIBVERMAJOR) $(LIBDIR)/$(LIB_SHARED); \
+- if test `uname` = "Linux"; then \
+- if test $(LIBDIR) = "/lib" || test $(LIBDIR) = "/usr/lib"; then \
+- echo "" > /dev/null; \
+- elif grep -q $(LIBDIR) /etc/ld.so.conf > /dev/null 2>&1; then \
+- echo "" > /dev/null; \
+- else \
+- echo "Unable to find $(LIBDIR) in ld.so.conf. In order to use "; \
+- echo "$(LIB_SHARED), you may need to add it or set LD_LIBRARY_PATH."; \
+- fi; \
+- echo "$(LDCONFIG)"; \
+- $(LDCONFIG); \
+- fi \
+ )
+
+ install.cyg:
+@@ -393,8 +366,8 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS) config.h
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+- $(LIB_OBJS)
++ $(CC) -shared $(USER_LD_FLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(LIB_OBJS) $(LIBRARIES)
+
+ install.man:
+ @if [ -d doc/man ] ; then \