summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 17:35:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 18:05:50 +0100
commitbe923f59cb9d22532d382767d82bb73e14f3d451 (patch)
treebfddd2ccd72b7f1460d5103824c888b0dde285b6 /media-libs/libaom/libaom-9999.ebuild
parentmedia-libs/libaom: Drop obsolete patch, pkg uses GNUInstallDirs now (diff)
downloadgentoo-be923f59cb9d22532d382767d82bb73e14f3d451.tar.gz
gentoo-be923f59cb9d22532d382767d82bb73e14f3d451.tar.bz2
gentoo-be923f59cb9d22532d382767d82bb73e14f3d451.zip
media-libs/libaom: EAPI-7 bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libaom/libaom-9999.ebuild')
-rw-r--r--media-libs/libaom/libaom-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 18d07c799737..67f5b2163ddd 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit cmake-multilib
if [[ ${PV} == *9999* ]]; then
@@ -28,8 +29,12 @@ IUSE="doc examples"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"
-RDEPEND=""
-DEPEND="abi_x86_32? ( dev-lang/yasm )
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="abi_x86_32? ( dev-lang/yasm )
abi_x86_64? ( dev-lang/yasm )
abi_x86_x32? ( dev-lang/yasm )
x86-fbsd? ( dev-lang/yasm )
@@ -37,11 +42,6 @@ DEPEND="abi_x86_32? ( dev-lang/yasm )
doc? ( app-doc/doxygen )
"
-REQUIRED_USE="
- cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
-"
-
PATCHES=( "${FILESDIR}/pthread_lib2.patch" )
multilib_src_configure() {
@@ -63,16 +63,13 @@ multilib_src_configure() {
-DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
-
- -DBUILD_SHARED_LIBS=ON
)
cmake-utils_src_configure
}
multilib_src_install() {
- cmake-utils_src_install
if multilib_is_native_abi && use doc ; then
- docinto html
- dodoc docs/html/*
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
+ cmake-utils_src_install
}