summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHector Martin <marcan@marcan.st>2017-12-09 06:25:10 +0900
committerMichael Palimaka <kensington@gentoo.org>2017-12-09 20:46:03 +1100
commit6dd1c348da56ab8a1601477b9b844488833327aa (patch)
tree0df744fb62051e7d2aa47840497f6b456dc48efc /media-libs/libffado
parentdev-libs/libite: fix failing tests (diff)
downloadgentoo-6dd1c348da56ab8a1601477b9b844488833327aa.tar.gz
gentoo-6dd1c348da56ab8a1601477b9b844488833327aa.tar.bz2
gentoo-6dd1c348da56ab8a1601477b9b844488833327aa.zip
media-libs/libffado-2.3.0: Fix build with new glibc
Closes: https://bugs.gentoo.org/640286 Closes: https://github.com/gentoo/gentoo/pull/6486 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-libs/libffado')
-rw-r--r--media-libs/libffado/Manifest2
-rw-r--r--media-libs/libffado/files/libffado-2.3.0-include-signal.patch29
-rw-r--r--media-libs/libffado/libffado-2.3.0.ebuild1
3 files changed, 31 insertions, 1 deletions
diff --git a/media-libs/libffado/Manifest b/media-libs/libffado/Manifest
index dd5225ee1b83..db5966e713e0 100644
--- a/media-libs/libffado/Manifest
+++ b/media-libs/libffado/Manifest
@@ -1 +1 @@
-DIST libffado-2.3.0.tgz 1239253 SHA256 18e3c7e610b7cee58b837c921ebb985e324cb2171f8d130f79de02a3fc435f88 SHA512 24a8853281a17b04623e41dc590f7a9b8f4aebe4dfaece2e3b8fe28457a6ff011586e817712b4913d1fca660b701dddc70576c12d8c56470cf991eb17b4297c4 WHIRLPOOL 8eb1c3f6372b25b173d230500cfad7ef7207d730ec8e048bdb84cd7436e196e5429d85afcea0f626a411c1f792f20f1ab59f0c0b0f5a97b114f646c4a7423053
+DIST libffado-2.3.0.tgz 1239253 BLAKE2B cb470a590df8018975f40f56cde50468a2b51c9504b719b70ce5941406829f25452a96b8ac897aba1ed6c8d4cafa712e7872430e7bb2ebec0822f7b4720084c5 SHA512 24a8853281a17b04623e41dc590f7a9b8f4aebe4dfaece2e3b8fe28457a6ff011586e817712b4913d1fca660b701dddc70576c12d8c56470cf991eb17b4297c4
diff --git a/media-libs/libffado/files/libffado-2.3.0-include-signal.patch b/media-libs/libffado/files/libffado-2.3.0-include-signal.patch
new file mode 100644
index 000000000000..4eabf12eef05
--- /dev/null
+++ b/media-libs/libffado/files/libffado-2.3.0-include-signal.patch
@@ -0,0 +1,29 @@
+------------------------------------------------------------------------
+r2706 | jwoithe | 2017-08-08 08:39:56 +0900 (Tue, 08 Aug 2017) | 11 lines
+
+PosixMessageQueue: ensure visibility of SIGEV_THREAD declaration.
+
+Orcan Ogetbil reported on the ffado-devel list that during the recent Fedora
+rebuild effort FFADO 2.3.0 failed to compile because SIGEV_THREAD was
+undeclared. Jano Svitok made the plausible suggestion that signal.h needs
+to be included explicitly under newer glibc versions. This trivial patch
+implements this. As of this commit it has not been verified that the
+problem is fixed with this addition. However, there's no harm done by the
+change in general and conceptionally the change is consistent with the
+source file's content given the use of signal-related functionality.
+
+
+Index: src/libutil/PosixMessageQueue.cpp
+===================================================================
+--- a/src/libutil/PosixMessageQueue.cpp (revision 2705)
++++ b/src/libutil/PosixMessageQueue.cpp (revision 2706)
+@@ -30,6 +30,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <poll.h>
++#include <signal.h>
+
+ #define MQ_INVALID_ID ((mqd_t) -1)
+ // one second
+
+------------------------------------------------------------------------
diff --git a/media-libs/libffado/libffado-2.3.0.ebuild b/media-libs/libffado/libffado-2.3.0.ebuild
index 5aa6ee2a3f32..c5e50c2d21d5 100644
--- a/media-libs/libffado/libffado-2.3.0.ebuild
+++ b/media-libs/libffado/libffado-2.3.0.ebuild
@@ -46,6 +46,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/libffado-2.3.0-modelname-strip.patch"
"${FILESDIR}/libffado-2.3.0-gcc6.patch"
+ "${FILESDIR}/libffado-2.3.0-include-signal.patch"
)
myescons() {