summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-05 03:24:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-05 03:26:34 +0200
commit9e754bf0d0efb0f5099d3af1a9216a860cbfeafa (patch)
treeee9e3cb3589c9b49886a21e3cfc7e6a304696ed6 /media-libs/libheif/libheif-1.5.1.ebuild
parentmedia-libs/libheif: bump to v1.4.1 (diff)
downloadgentoo-9e754bf0d0efb0f5099d3af1a9216a860cbfeafa.tar.gz
gentoo-9e754bf0d0efb0f5099d3af1a9216a860cbfeafa.tar.bz2
gentoo-9e754bf0d0efb0f5099d3af1a9216a860cbfeafa.zip
media-libs/libheif: bump to v1.5.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/libheif/libheif-1.5.1.ebuild')
-rw-r--r--media-libs/libheif/libheif-1.5.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/libheif/libheif-1.5.1.ebuild b/media-libs/libheif/libheif-1.5.1.ebuild
new file mode 100644
index 000000000000..5bc23c4b37c5
--- /dev/null
+++ b/media-libs/libheif/libheif-1.5.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools xdg-utils multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.5"
+IUSE="static-libs test +threads"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}