summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libjsw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libjsw')
-rw-r--r--media-libs/libjsw/Manifest1
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.8-build.patch110
-rw-r--r--media-libs/libjsw/libjsw-1.5.8.ebuild45
-rw-r--r--media-libs/libjsw/metadata.xml8
4 files changed, 164 insertions, 0 deletions
diff --git a/media-libs/libjsw/Manifest b/media-libs/libjsw/Manifest
new file mode 100644
index 000000000000..fe84100377e2
--- /dev/null
+++ b/media-libs/libjsw/Manifest
@@ -0,0 +1 @@
+DIST libjsw-1.5.8.tar.bz2 348121 SHA256 082461dbf67efbd7e682b0675b0ced36430c5b1abc152c977e41b98de68fc811 SHA512 b858ed124366bd2df6710c07d82a447cc7227f1e442b3a3652d50734d97edef45b42b5a8bf84d4675c0130ab4da080a8409bfb6e1c80cb747930ac431dbf1226 WHIRLPOOL d85de409b805e64acf1433a4cd872e5816e95ed4e4f39825e2fa91d5e2ebb07037f78e67a27ad785fd5ecab04ceeef8f37cdfe3a11e1ea01f435838f53e896a1
diff --git a/media-libs/libjsw/files/libjsw-1.5.8-build.patch b/media-libs/libjsw/files/libjsw-1.5.8-build.patch
new file mode 100644
index 000000000000..d786195058c1
--- /dev/null
+++ b/media-libs/libjsw/files/libjsw-1.5.8-build.patch
@@ -0,0 +1,110 @@
+--- libjsw/Makefile.old 2010-03-22 17:03:21.000000000 +0100
++++ libjsw/Makefile 2010-03-22 17:07:02.000000000 +0100
+@@ -51,10 +51,10 @@
+ # to debug the program.
+ #
+
+-CFLAGS = -Wall -O2 -g
+-CFLAGS += -ffast-math
++CFLAGS += -fPIC
++CXXFLAGS += -fPIC
+
+-CPPFLAGS = -D__cplusplus
++CPPFLAGS += -D__cplusplus
+
+
+ # ########################################################################
+@@ -82,11 +82,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -95,13 +93,7 @@
+ $(LIB): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -Wl,-soname=$(LIB) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @$(RM) $(RMFLAGS) $(LIBPFX).so
+- @$(LINK) -s $(LIB) $(LIBPFX).so
+- @$(LINK) -s $(LIB) $(LIBPFX).so.1
+- @-$(LS) $(LSFLAGS) $(LIB)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(LIB) $(LDFLAGS) $(LIBS) $(LIB_DIRS)
+
+ prebuild:
+ @echo "Building library \"$(LIB)\"..."
+--- jscalibrator/Makefile.old 2010-03-22 17:08:07.000000000 +0100
++++ jscalibrator/Makefile 2010-03-22 17:11:26.000000000 +0100
+@@ -59,9 +59,6 @@
+ #CFLAGS = -Wall -O -g \
+ # `gtk-config --cflags`
+
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -funroll-loops -ffast-math \
+- `gtk-config --cflags`
+-
+ CPPFLAGS = -D__cplusplus
+
+
+@@ -76,7 +73,7 @@
+ # to the LIB line depending on what you have set in the CFLAGS line
+ # farther above.
+ #
+-LIBS = -ljsw `gtk-config --libs`
++LIBS := -ljsw $(shell gtk-config --libs)
+
+ # Library Directories:
+ #
+@@ -85,7 +82,7 @@
+ # Each argument is of the format -L<dir> where <dir> is the full
+ # path to the directory.
+ #
+-LIB_DIRS =
++LIB_DIRS = -L../libjsw
+
+ # Header File Directories:
+ #
+@@ -95,7 +92,7 @@
+ # Each argument is of the format -I<dir> where <dir> is the full
+ # path to the directory.
+ #
+-INC_DIRS =
++INC_DIRS = $(shell gtk-config --cflags) -I../libjsw
+
+
+ # ########################################################################
+@@ -117,11 +114,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -130,10 +125,7 @@
+ $(BIN): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
++ $(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LDFLAGS) $(LIB_DIRS) $(LIBS)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
diff --git a/media-libs/libjsw/libjsw-1.5.8.ebuild b/media-libs/libjsw/libjsw-1.5.8.ebuild
new file mode 100644
index 000000000000..9816860e3b8e
--- /dev/null
+++ b/media-libs/libjsw/libjsw-1.5.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="provide a uniform API and user configuration for joysticks and game controllers"
+HOMEPAGE="http://freshmeat.net/projects/libjsw/"
+SRC_URI="http://wolfsinger.com/~wolfpack/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ cp include/jsw.h libjsw/
+ epatch "${FILESDIR}"/${P}-build.patch
+ bunzip2 libjsw/man/* || die
+}
+
+src_compile() {
+ LDFLAGS+=" -Wl,-soname,libjsw.so.1"
+ cd libjsw
+ emake
+ ln -s libjsw.so.${PV} libjsw.so
+}
+
+src_install() {
+ insinto /usr/include
+ doins include/jsw.h
+
+ dodoc README
+ docinto jswdemos
+ dodoc jswdemos/*
+
+ cd "${S}"/libjsw
+ dolib.so libjsw.so.${PV}
+ dosym libjsw.so.${PV} /usr/$(get_libdir)/libjsw.so
+ dosym libjsw.so.${PV} /usr/$(get_libdir)/libjsw.so.1
+ doman man/*
+}
diff --git a/media-libs/libjsw/metadata.xml b/media-libs/libjsw/metadata.xml
new file mode 100644
index 000000000000..a57a2b839230
--- /dev/null
+++ b/media-libs/libjsw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="freshmeat">libjsw</remote-id>
+ </upstream>
+</pkgmetadata>