summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/liblrdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/liblrdf')
-rw-r--r--media-libs/liblrdf/Manifest1
-rw-r--r--media-libs/liblrdf/liblrdf-0.5.0.ebuild46
-rw-r--r--media-libs/liblrdf/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/liblrdf/Manifest b/media-libs/liblrdf/Manifest
new file mode 100644
index 000000000000..0afa442f21f2
--- /dev/null
+++ b/media-libs/liblrdf/Manifest
@@ -0,0 +1 @@
+DIST liblrdf-0.5.0.tar.gz 283109 SHA256 013002b91ef209827fe99552b8c7f0b569cddb3d6f1439bedbd8bafe1956a93c
diff --git a/media-libs/liblrdf/liblrdf-0.5.0.ebuild b/media-libs/liblrdf/liblrdf-0.5.0.ebuild
new file mode 100644
index 000000000000..c9e602e3d93e
--- /dev/null
+++ b/media-libs/liblrdf/liblrdf-0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="A library for the manipulation of RDF file in LADSPA plugins"
+HOMEPAGE="http://github.com/swh/LRDF"
+SRC_URI="http://github.com/swh/LRDF/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1
+ media-libs/raptor:2
+ >=media-libs/ladspa-sdk-1.12"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_unpack() {
+ unpack ${A}
+ mv *-LRDF-* "${S}"
+}
+
+src_prepare() {
+ sed -i -e 's:usr/local:usr:' examples/{instances,remove}_test.c || die #392221
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ has_version media-plugins/swh-plugins && default #392221
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/lib*/liblrdf.la
+}
diff --git a/media-libs/liblrdf/metadata.xml b/media-libs/liblrdf/metadata.xml
new file mode 100644
index 000000000000..7bbcd54ed8d3
--- /dev/null
+++ b/media-libs/liblrdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="github">swh/LRDF</remote-id>
+ </upstream>
+</pkgmetadata>