summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libmediaart/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libmediaart/files')
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
new file mode 100644
index 000000000000..ecf9de908cfd
--- /dev/null
+++ b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
@@ -0,0 +1,47 @@
+Solves automagic selection of Qt version.
+
+https://bugs.gentoo.org/show_bug.cgi?id=523122
+https://bugzilla.gnome.org/show_bug.cgi?id=737174
+
+diff --git a/configure.ac b/configure.ac
+index e9ead09..3ee710a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
+ AS_HELP_STRING([--enable-qt],
+ [enable Qt support, (MP3 album art) [[default=auto]]]),,
+ [enable_qt=auto])
++AC_ARG_WITH(qt-version,
++ AS_HELP_STRING([--with-qt-version=major],
++ [Force specific Qt version [[default=auto]]]),,
++ [with_qt_version=auto])
+
+ selected_for_media_art="no (disabled)"
+
+@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
+ fi
+
+ if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
+- PKG_CHECK_MODULES(QT5,
+- [Qt5Gui >= $QT5_REQUIRED],
+- [have_qt5=yes],
+- [have_qt5=no])
+- PKG_CHECK_MODULES(QT4,
+- [QtGui >= $QT4_REQUIRED],
+- [have_qt4=yes],
+- [have_qt4=no])
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
++ PKG_CHECK_MODULES(QT5,
++ [Qt5Gui >= $QT5_REQUIRED],
++ [have_qt5=yes],
++ [have_qt5=no])
++ fi
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
++ PKG_CHECK_MODULES(QT4,
++ [QtGui >= $QT4_REQUIRED],
++ [have_qt4=yes],
++ [have_qt4=no])
++ fi
+
+ if test "x$have_qt5" = "xyes"; then
+ BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"