summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:22:11 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:24:29 +0100
commit78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085 (patch)
tree682ddacec40f41180a95055f293756e71c3fbd61 /media-libs/libmediaart
parentsys-apps/fakeroot: stable 1.22 for sparc, bug #635850 (thanks to Rolf Eike Beer) (diff)
downloadgentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.tar.gz
gentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.tar.bz2
gentoo-78ca36b4f62b9bbe20b48dd1bfaee7a2f984e085.zip
*/*: revert https://github.com/gentoo/gentoo/pull/5828.
This commit adds back the string of commits from PR 5828.
Diffstat (limited to 'media-libs/libmediaart')
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
new file mode 100644
index 000000000000..ecf9de908cfd
--- /dev/null
+++ b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
@@ -0,0 +1,47 @@
+Solves automagic selection of Qt version.
+
+https://bugs.gentoo.org/show_bug.cgi?id=523122
+https://bugzilla.gnome.org/show_bug.cgi?id=737174
+
+diff --git a/configure.ac b/configure.ac
+index e9ead09..3ee710a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
+ AS_HELP_STRING([--enable-qt],
+ [enable Qt support, (MP3 album art) [[default=auto]]]),,
+ [enable_qt=auto])
++AC_ARG_WITH(qt-version,
++ AS_HELP_STRING([--with-qt-version=major],
++ [Force specific Qt version [[default=auto]]]),,
++ [with_qt_version=auto])
+
+ selected_for_media_art="no (disabled)"
+
+@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
+ fi
+
+ if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
+- PKG_CHECK_MODULES(QT5,
+- [Qt5Gui >= $QT5_REQUIRED],
+- [have_qt5=yes],
+- [have_qt5=no])
+- PKG_CHECK_MODULES(QT4,
+- [QtGui >= $QT4_REQUIRED],
+- [have_qt4=yes],
+- [have_qt4=no])
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
++ PKG_CHECK_MODULES(QT5,
++ [Qt5Gui >= $QT5_REQUIRED],
++ [have_qt5=yes],
++ [have_qt5=no])
++ fi
++ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
++ PKG_CHECK_MODULES(QT4,
++ [QtGui >= $QT4_REQUIRED],
++ [have_qt4=yes],
++ [have_qt4=no])
++ fi
+
+ if test "x$have_qt5" = "xyes"; then
+ BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"