summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-29 14:00:03 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-01-30 03:44:44 +1100
commit720a7f364f5aaa5de43d4e6bdf61d21757f7da06 (patch)
tree1f342a184f970e56200424f24a212dd0780bb0c3 /media-libs/libopenshot
parentdev-perl/Locale-gettext: dropped ~ia64-linux (diff)
downloadgentoo-720a7f364f5aaa5de43d4e6bdf61d21757f7da06.tar.gz
gentoo-720a7f364f5aaa5de43d4e6bdf61d21757f7da06.tar.bz2
gentoo-720a7f364f5aaa5de43d4e6bdf61d21757f7da06.zip
media-libs/libopenshot: bump to 0.1.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/libopenshot')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/files/libopenshot-0.1.3-fix-tests.patch26
-rw-r--r--media-libs/libopenshot/libopenshot-0.1.3.ebuild85
-rw-r--r--media-libs/libopenshot/metadata.xml1
4 files changed, 112 insertions, 1 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index 9742eff31825..3d00751dfa5b 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1,3 +1,4 @@
DIST libopenshot-0.1.0.tar.gz 10970157 SHA256 1eb3cc27d9d5a5c966dd5dd445567239c6cbcc08772ba99e5f3b52c87a28d809 SHA512 bd5767b96ae38da7f31bfcca3ec5b34c458ab271d3e899b1982cd09b0576d29a3101c54fc840766d40aa7cbc83130064f0440f5c465999f0518449318ab87480 WHIRLPOOL c485271357545e85b94753659f0a58f4e7b0f4c4ee2a4d53bbcb1d650a3cef730103b73577848d0e2e6a355d42788451fbc1839c82343b2f172c3fd725906f29
DIST libopenshot-0.1.1.tar.gz 10970421 SHA256 7f79084b0fda085ee5740f4907a2ac4bd736de6b3c4958b4441f49eaedfc7eee SHA512 7ed329b8a066ace9996342504ce817cd0e20a8599a71fa6483d8b2eeb52b5bfeed0cb4b9d099c34a275fc529d55d1bd0527707264ddd5d106574ee25e4fcd3ec WHIRLPOOL 9a759029f4b0ff1510157c91ac09f67c665446b5551487c6d228c2a668b019bb919aae53e5813b541863d32116017f0fc2a19dbc008e307e3bc9c32cc72df884
DIST libopenshot-0.1.2.tar.gz 11012039 SHA256 f5b37250aaa4f7ca29727966b818d73d6a100d92dbb7bc5270ee332f820a3657 SHA512 a713b24c5925ea99f5b749e178a635dd30d1ed666d8a1195beaabd44fd4d8b4e5282ee0fda2fef58dc5db3e1a481f535902496128142c445082130a08841540e WHIRLPOOL 7902060db5e5d4ff4136057f33f0c6149827cfa9000bae70f7271ddabe608b5672caaa3dececb68517f4419b36ecd89fb718caa9823e214203fcfc1c648d5536
+DIST libopenshot-0.1.3.tar.gz 11019740 SHA256 4a35318af4fbeeb0c658963275e8ec1edb985497ab9674d76eb02a1d72cbb64d SHA512 d59817505812868db408a88dc1d30b5b1833910f45dd0df03937110b7d4cbd85a270773008e75a1501f4b3b89a09ea798ed9b580755adf3ae79ac24d403f6982 WHIRLPOOL 31e7b7fe98e2709d1d88c6e2c39ceaa0b81c4f9a624ea9853ffd9b86771148e1bec808ec67192cede3578bc30860f8f5a878f67745d2d2ac9838ea93f01b628c
diff --git a/media-libs/libopenshot/files/libopenshot-0.1.3-fix-tests.patch b/media-libs/libopenshot/files/libopenshot-0.1.3-fix-tests.patch
new file mode 100644
index 000000000000..8ed3102b7adc
--- /dev/null
+++ b/media-libs/libopenshot/files/libopenshot-0.1.3-fix-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 29fbe45..ff67cb5 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -24,16 +24,19 @@
+ # along with OpenShot Library. If not, see <http://www.gnu.org/licenses/>.
+ ################################################################################
+
++SET(TEST_MEDIA_PATH "${openshot_SOURCE_DIR}/src/examples/")
+
+ ################ WINDOWS ##################
+ # Set some compiler options for Windows
+ # required for libopenshot-audio headers
+ IF (WIN32)
+- STRING(REPLACE "/" "\\\\" TEST_MEDIA_PATH "${openshot_SOURCE_DIR}/src/examples/")
+- add_definitions( -DIGNORE_JUCE_HYPOT=1 -DTEST_MEDIA_PATH="${TEST_MEDIA_PATH}" )
++ STRING(REPLACE "/" "\\\\" TEST_MEDIA_PATH TEST_MEDIA_PATH)
++ add_definitions( -DIGNORE_JUCE_HYPOT=1 )
+ SET(CMAKE_CXX_FLAGS " ${CMAKE_CXX_FLAGS} -include cmath -std=c++0x")
+ ENDIF(WIN32)
+
++add_definitions( -DTEST_MEDIA_PATH="${TEST_MEDIA_PATH}" )
++
+ ################### UNITTEST++ #####################
+ # Find UnitTest++ libraries (used for unit testing)
+ FIND_PACKAGE(UnitTest++ REQUIRED)
diff --git a/media-libs/libopenshot/libopenshot-0.1.3.ebuild b/media-libs/libopenshot/libopenshot-0.1.3.ebuild
new file mode 100644
index 000000000000..d07deb81db83
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.1.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit cmake-utils python-single-r1 toolchain-funcs versionator
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="http://www.openshotvideo.com/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+imagemagick libav +python test"
+# https://github.com/OpenShot/libopenshot/issues/43
+RESTRICT="test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/cppzmq
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ media-libs/libopenshot-audio
+ imagemagick? ( media-gfx/imagemagick:0=[cxx] )
+ libav? ( media-video/libav:=[encode,x264,xvid,vpx,mp3,theora] )
+ !libav? ( media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ test? ( dev-libs/unittest++ )
+"
+
+# https://github.com/OpenShot/libopenshot/pull/45
+PATCHES=( ${FILESDIR}/${P}-fix-tests.patch )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ -DCMAKE_DISABLE_FIND_PACKAGE_ImageMagick=$(usex !imagemagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ emake test
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize
+}
diff --git a/media-libs/libopenshot/metadata.xml b/media-libs/libopenshot/metadata.xml
index 1c216c0849dd..27f9c3bcefe5 100644
--- a/media-libs/libopenshot/metadata.xml
+++ b/media-libs/libopenshot/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>